IBM Support

KDY2034E and 0x80040705 errors when installing the Windows (NT) OS agent

Troubleshooting


Problem

On rare occasions the installation of a Windows NT agent may fail due to a missing, corrupt or problematic path variable.

Symptom

Remote and local installations fail with these errors on the screen or in the Abort_IBM_Tivoli_Monitoring_########_####.log.

During a remote deploy the NT agent shows:
Error Message : KDY2034E: Unable to connect to host winserver.company.com using the
provided credentials on the following protocol(s):
[SMB| SSH| REXEC| RSH]. An attempt was made to connect to the target
host using the provided credentials, but that attempt failed.

During a local installation this message may appear
Error Number: 0x80040705
Description: String Accessed out of bounds

Cause

System path problems such as:
* Missing or corrupt path
* Path is too long

Diagnosing The Problem

Messages similar to these will appear in the Abort_IBM_Tivoli_Monitoring_########_####.log if the path is missing or unreadable.

8-23-2012 10:10:20 RegistryGetKeyValueXX
Key(HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment)
Value(Path) ERROR:The system cannot find the file specified.

Resolving The Problem

For missing or corrupt path:
Verify the path exists by running the "path" command from the Command Line Interface (CLI) or copy the path statement from a working system onto the problematic server.

If path is too long:
For a variable longer than 1024 characters do the following:

1. From MyComputer -> right click and select Properties -> select Advanced ->
select Environment Variables.

* Under System Variables find Path and edit it.

* In the variable name change Path to Pathsave and press OK.

* Select Pathsave and edit it.

* Change Pathsave back to Path and change the value to the minimum you can install with.

* If uncertain try:
%System root% \system32;%System root%;%System root% \system32\Wbem

2. Once the install is complete.

3. Edit the Path variable again to delete it and rename Pathsave to
path.

4. The length can be determined by DOS Command set path >c:\pathfile.txt

5. Edit the file and remove pathext variable and save the result.

The new file length is the length of the Path variable.

***

If the problem has not been resolved with the steps provided above then attempt the installation again using these instructions.

1. Shut down as many applications as possible on this windows box prior to attempting the install to minimize processes that may conflict with the installation.

2. The InstallVerbose.log referenced below can be created on any
directory or drive other than the root directory or C drive. However,
if a different directory is specified, it must exist prior to running the
setup command.

3. Prior to the install run this command:
setup /verbose"c:\InstallVerbose.log"

Note: There is no space between verbose and the log filename

4. Run the installation again locally

5. If installation still fails and cannot be resolved with this technote,
open a PMR and send IBM support the InstallVerbose.log and
Abort_IBM_Tivoli_Monitoring_########_####.log

[{"Product":{"code":"SSTFXA","label":"Tivoli Monitoring"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"06.2.3.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21609652