IBM Support

Unable to recognize services or query JTS discovery HTTP status 503 error

Troubleshooting


Problem

Attempts to use the CLM Server results in a permission error after logging in when using IBM Rational Quality Manager.

Symptom

Here is the full error message:

You are currently logged in to the Admin Web UI as a user without JazzAdmin permissions. Most of the functionality will be unavailable. If you believe you should have full access, please contact your administrator.

The Jazz Team Server (JTS) will not load and you see errors in the log including:

WARN net.jazz.web.app.internal.about.ConsolidatedAbout   - Unable to recognize about services: Unable to query JTS discovery : https://jazz:9443/jts/discovery?type=http%3A%2F%2Fjazz.net%2Fxmlns%2Fprod%2Fjazz%2Fdiscovery%2F1.0%2FApplication&scope=includeExternal: HTTP status:503:Service Unavailable.

AND



http-9443-Processor24] ERROR t.internal.registry.AbstractActivationManagerOwner  - CRJAZ1093I The following service class was not activated: "com.ibm.team.repository.service.internal.distributed.RepoCacheService"

The key error is about the ObjectGrid:

java.lang.UnsupportedOperationException: The ObjectGrid libraries are not available to create a distributed map service.

CRJAZ1972E The service "com.ibm.team.repository.service.internal.RepositoryItemService" failed to activate because a service it depends on, "com.ibm.team.repository.service.IRepositoryItemAccessValidationService", failed to be activated

Cause

These two properties are in the JTS teamserver.properties file and you are not using version 4.x or you are not trying to setup Tomcat application server clustering:

com.ibm.team.repository.cluster.id=
com.ibm.team.repository.cluster.catalogServerURL=

This is a product defect.

Diagnosing The Problem

Whether or not the directives have a value is not the problem. They should not be in the teamserver.properties file in a 3.x environment. Though the interface allows you to enter them, the interface cannot recover from incorrect values or allow you to remove them to fix the problem.

Resolving The Problem

Remove or comment out these cluster settings in the teamserver.properties file:

com.ibm.team.repository.cluster.id=

com.ibm.team.repository.cluster.catalogServerURL=

After you save the file changes, restart the JTS.

[{"Product":{"code":"SSUVV6","label":"IBM Engineering Test Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Team Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.0.1;3.0.1.1;3.0.1.2;3.0.1.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Product Synonym

Rational Quality Manager

Document Information

Modified date:
16 June 2018

UID

swg21591564