IBM Support

ITM Birt reports showing wrong time

Troubleshooting


Problem

In a Russian Windows system, the BIRT reports show a wrong time on both the footer section and the input fields: GMT+3 is used instead of the expected GMT+4.

Symptom

From March 27th 2011, Russia moved to DST (GMT+4) and this one became the new Russian Standard Time.This means that at the end of the DST period, the timezone will continue to be GMT+4 instead of GMT+3.
In order to accomplish to this new rule, the Windows operating system has been patched with Microsoft package and all the Java JREs (including TCR ones) have been also updated using the JTZU tool.
Despite of these required changes, BIRT reports created by TCR are showing GMT+3 instead of the expected GMT+4.
The system clock is showing the correct time, the TCR logs are also showing entries with the correct time.
Running Cognos Reports, the footer time is the expected one as well as the default time showed in the input fields.
This clearly indicates the problem to be with the Birt Engine.
An additional test demonstrates that also the BIRT Report Designer tool V2.2.1 (the one used to develop the ITM BIRT reports) - when running on the same systems - shows this behavior, confirming our previous assumption about the BIRT engine failure.
The problem does not occur with BIRT Engine V3.7.x, but anyway TCR only supports V2.2.1 and it cannot be updated.

Cause

The BIRT Engine leverages on the Java timezone table (Olson table) and we know that all the JREs have been correctly patched on the failing system.
The problem is with the internal methods used by the BIRT engine, which have been changed in the more recent engine releases.
So this is not a TCR failure nor a problem with the ITM BIRT reports.

Resolving The Problem

Since nothing can be changed on the TCR side, because it only supports BIRT Engine V2.2.1, we have two options to bypass the problem:
1) Use the Cognos Reports instead of the BIRT reports
2) Manually modify the BIRT reports by using the BIRT Report designer V2.2.1 in order to force the BIRT engine using a fixed timezone.This action would require all needed reports to be modified and then reimported into TCR.
In order to accomplish this change, please follow these steps:
a) download the BIRT Report Designer V2.2.1 from the following link ((on "Report Designer Full Eclipse Install" section):
http://archive.eclipse.org/birt/downloads/build.php?build=R-R1-2_2_1-200710010630
b) run the BIRT Report Designer and open the ITM Report you want to modify
c) select the "Script" tab and then choose "Initialize" from the drop-down list
d) insert the following lines in the body:

importPackage(Packages.com.ibm.icu.util);
Packages.com.ibm.icu.util.TimeZone.setDefault(TimeZone.getTimeZone("GMT+4:00"));

At report initialization time, the "Initialize" method will be invoked so setting the fixed default timezone you previously chose instead of the one retrieved by the Java methods.

It should look like this:



e) save the new report definition and repeat steps c) and d) for each of the reports you need to change
f) reimport the changed BIRT reports into TCR

[{"Product":{"code":"SSTFXA","label":"Tivoli Monitoring"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Tivoli Common Reporting TCR","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2.1.1;2.1;1.3;1.2.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

IBM Tivoli Monitoring Tivoli Common Reporting

Document Information

Modified date:
17 June 2018

UID

swg21579141