IBM Support

db2start receives error ADM12008C. The product "DB2 Advanced Enterprise Server Edition" does not have a valid license installed and the evaluation period has expired.

Troubleshooting


Problem

When installing DB2 Connect Server on Windows, the installation media provides the ability to install any of the DB2 Server products. If the first product listed is selected, DB2 Advanced Enterprise Server Edition (AESE) will install. This will succeed and allow the the DB2 Connect Server License to be applied. The instance will function as expected. After 90 days, the AESE license will expire and DB2 will no longer start, returning error ADM12008C. The problem will also occur if you choose the second product available which is DB2 Enterprise Server Edition (ESE). You will not see the licensing issue if you install DB2 Workgroup Server Edition (WSE).

Symptom

After running DB2 instance for 90 days the following error occurs on db2start:

ADM12008C The product "DB2 Advanced Enterprise Server Edition" does not have a valid license key installed and the evaluation period has expired. Functions specific to this product are not enabled. If you have licensed this product, please ensure the license key is properly installed. You can install the license via using License Center or db2licm command line utility. The license file can be obtained from your licensed product CD.

db2licm -l will show:

Product name: "DB2 Advanced Enterprise Server Edition"


Expiry date: "Expired"
Product identifier: "db2aese"
Version information: "9.7"

Product name: "DB2 Connect Enterprise Edition"
License type: "User"
Expiry date: "Permanent"
Product identifier: "db2consv"
Version information: "9.7"
Concurrent connect user policy: "Disabled"
Enforcement policy: "Soft Stop"
Number of licensed authorized users: "20"

Cause

The product installed was DB2 Advanced Enterprise Server Edition which is first product listed when the Installer for DB2 Server is launched on a Windows Server. The intended product was DB2 Connect Enterprise Edition.
This issue is not apparent until the trial period of 90 days expires since DB2 Connect can be licensed for a DB2 AESE Server.
Once the trial 90 day period expires, a DB2 Advanced Enterprise Server Edition instance will no longer start until the license has been applied. In this case, it is the license for DB2 Advanced Enterprise Server Edition.

Environment

DB2 Connect on Windows platforms

Diagnosing The Problem

Run : db2licm -l

and determine which product license is expired.

Resolving The Problem

To resolve the problem there are 2 options.

Option 1: Install DB2 Connect Server, then remove DB2 Advanced Enterprise Server Edition

Step 1) To resolve issue of db2start failure, after the DB2 AESE license expires, the instance needs to be recreated as a WSE (Workgroup Server Edition) instance. The default instance type when running DB2 AESE is an ESE instance. db2start will look at the instance type and if ESE (Enterprise Server Edition) is returned, the db2start will fail with the ADM12008C error.
Do the following:

a) set DB2INSTANCE=DB2
where DB2 is the instance name
b) backup the instance information
db2cfexp <filename> template
c) db2stop
d) db2idrop DB2
e) db2icrt -s WSE DB2
f) db2cfimp filename
g) db2 update dbm cfg using svcename db2c_DB2
where db2c_DB2 is setup in the Windows services file
h) db2set -all
check for db2comm=tcpip
db2set db2comm=tcpip if not set.
Verify that the dbm cfg parameters have been set.
i) db2start
The SQL8008N error will still be returned at this point indicating a license for DB2 Advanced Enterprise Edition has not been added, but since there are no ESE instances, DB2 will start.

Step 2) How to remove DB2 AESE installation and have DB2 Connect Server installed

a) From the same DB2 Version and fixpak level file launch the install. Make sure to choose the correct product to install by scrolling until the product DB2 Connect Server is displayed. NOTE that DB2 AESE (Advanced Server Edition) is the first product listed and most likely why it was installed.
From this choose, Work with Existing button, then select the same DB2COPYx that the DB2 AESE is installed.
Step through the install and complete installation.
b) Once DB2 Connect Server is installed, then relaunch the installer, this time choose install DB2 AESE (Advanced Server Edition) , work with existing, then choose
option to remove DB2 AESE. Once done, the message for the AESE expired license will no longer appear under db2licm -l and no errors will be seen on db2start.

Option 2: Remove the installation and install DB2 Connect Server
Step 1) Backup the configuration for the instance.
a) set DB2INSTANCE=DB2
where DB2 is the instance name
b) backup the instance information
db2cfexp <filename> template

Step 2) Using Add/Remove programs remove the DB2 AESE installation

Step 3) Install DB2 Connect Server, then import the configuration
a) Install DB2 Connect Server
b) import the configuration from the original instance
db2cfimp <filename.

[{"Product":{"code":"SSEPDU","label":"Db2 Connect"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation\/Migration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.7;9.5;10.1","Edition":"Application Server;Enterprise Server;Unlimited for System i;Unlimited for System z","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21576248