IBM Support

Issues installing and using WebSphere Application Server V8, IBM HTTP Server V8 on AIX 7.1 TL 1

Technote (troubleshooting)


Problem(Abstract)

You are installing WebSphere Application Server V8 and IBM HTTP Server V8 on AIX 7.1 and you encounter warnings during install. When you try to run any WebSphere service or tool you encounter this error:

Error: Port Library failed to initialize
Could not create the Java virtual machine.

Symptom

This issue only occurs for AIX 7.1 Technology Level (TL) 1, Service Pack (SP) 0 and 1. To determine if your operating system is at this level, you can run the following command.

oslevel -s

You will see a result like

7100-01-01-1141

This is TL 1, SP 1. The second number is TL. The third number is the SP.

Cause

The AIX team has discovered an issue (APAR IV09585) that is causing this error and they have delivered a fix.

Resolving the problem

You can fix the problem in one of three ways

  1. The fix is available in AIX 7.1 TL 1 SP 2. It is recommended to obtain the fix as part of SP2.
  2. If you cannot upgrade to SP2, you can download the APAR fix available from
    https://www-304.ibm.com/support/docview.wss?uid=isg1IV09585
  3. If you cannot do either of the first two options, then you can install an interim fix. This interim fix requires you to be at TL 1 , SP 1. Download the interim fix from
    ftp://public.dhe.ibm.com/aix/efixes/iv09585/
    1. Install the fix as root with the command
      emgr -e IV09585.epkg.Z
    2. Reboot your machine.

If you had already installed WebSphere Application Server V8 and IBM HTTP Server V8 , you should reinstall them to make sure all post-install scripts run correctly.


Cross Reference information
Segment Product Component Platform Version Edition
Software Development Rational ClearCase Installation AIX 8.0.0.1

Document information

More support for: Rational ClearQuest
Installation

Software version: 8.0.0.1

Operating system(s): AIX

Reference #: 1575120

Modified date: 15 December 2011