IBM Support

Diagnosing CPLEX error 32201 (Academic Initiative Users only)

Troubleshooting


Problem

My Academic Initiative version of CPLEX Optimization Studio does not operate due to a licensing error. What can I do?

Symptom

CPLEX error 32201, followed by an ILM error message.

Cause

Various.

Diagnosing The Problem

This error can only occur with versions 12.2 to 12.4 of CPLEX Optimization Studio obtained through the IBM Academic Initiative before May of 2012. Commercial licenses of CPLEX Optimization Studio do not use the ILOG License Manager (ILM) that issues this type of message. Starting in May 2012, Academic Initiative versions stopped using license files altogether, and this issue can no longer happen. If you have encountered this license error and remain eligible for an academic licenses, we recommend that you renew your academic license rather than try to resolve the license error. However, if you prefer to resolve the license error, the following discussion will probably help.

Resolving The Problem

Academic users of CPLEX Optimization Studio can only receive a very limited number of licensor errors, as the license key they use is very simple. While information on virtually all ILM error messages can be found by going to http://www.ibm.com/support and searching for "ILM Error" and the appropriate error number, that typically won't be necessary for an Academic Initiative user. Almost all Academic Initiative version license errors are one of the following, in order of likelihood.

  • "License not found or unreadable." This typically means the ILOG_LICENSE_FILE environment variable doesn't properly identify the full path of the license file, typically named access.ilm. It must specify the license file name in the path as well as the directory. This can also occur if the license file was corrupted during the download or installation process, or if the license file was never downloaded in the first place.
  • "No access key found for this product." This indicates that the license file is legitimate, but it doesn't enable the IBM ILOG components that comprise CPLEX Optimization Studio. These are CPLEX, OPL IDE, and CP Optimizer. Make sure you installed the correct license file, and that these products appear in the license keys. Also, make sure that the ILOG_LICENSE_FILE environment variable doesn't point to an old license file for another ILOG product.
  • "Too many open files trying to read key." This means that the processes running on the machine have used all available file descriptors when CPLEX tried to open the access.ilm file. Lack of any available file descriptors can also manifest itself with the "License not found or unreadable" error mentioned above. In either case, locate the process that uses an excessive number of file descriptors. The most likely explanation involves a CPLEX based application that repeatedly calls CPXopenCPLEX (when using the C API) or the IloCplex or Cplex constructors (when using C++, Java or .NET APIs). For example, this can happen in CPLEX applications that implement decomposition algorithms that solve a long sequence of problems, and each problem solve makes a license request. This is typically unnecessary, as usually the application can simply do one license request. Although it corresponds to a different error message, this FAQ describes the remedies in more detail.
  • "Access key has expired." Academic licenses have an expiration date and typically need to be renewed once a year.

If none of these resolve the problem, go to the CPLEX Optimizer Forum and search for error 32201. Given the limited number of possible error messages that can occur with an Academic Initiative license key, the odds are good that your problem has already been encountered and resolved. Otherwise, post the details of your problem on the forum.

[{"Product":{"code":"SSSA5P","label":"IBM ILOG CPLEX Optimization Studio"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF014","label":"iOS"}],"Version":"12.4;12.3;12.2.0.1;12.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21568759