IBM Support

Logical Block Protection (LBP) Support and the Firmware and Device Driver Version Requirements

Preventive Service Planning


Abstract

Firmware and Device Driver Requirements for Logical Block Protection Support

Content


To validate data and identify data that is corrupted, you can use a feature called logical block protection. If you use logical block protection, Tivoli® Storage Manager inserts a cyclic redundancy check (CRC) value at the end of each logical block of data to be written to tape.

By enabling logical block protection (LBP), you can identify errors that occur while data is being written to tape and while data is transferred from the tape drive to Tivoli Storage Manager through the storage area network. LBP may impact backup/restore performance.

Logical block protection is supported only on the following types of drives and media:

Drive
Tape media
Tape formats
Supported Tivoli Storage Manager
s erver versions
IBM TS1130 3592 Generation 3 3592-3 and 3592-3C 6.2.4, 6.3.1 and later
IBM TS1140 3592 Generation 3 3592-3 and 3592-3C 6.2.4, 6.3.1 and later
3592 Generation 4 3592-4 and 3592-4C 6.2.4, 6.3.1 and later
IBM TS1150 3592 Generation 4 3592-4 and 3592-4C 7.1.1 or later
3592 Generation 5 3592-5 and 3592-5C 7.1.1 or later
IBM LTO-5 LTO-5 ULTRIUM5 and ULTRIUM5C 6.2.4, 6.3.1 and later
IBM LTO-6 LTO-5 and LTO-6 ULTRIUM5, ULTRIUM5C,
ULTRIUM6, and ULTRIUM6C
6.2.5, 6.3.3 and later
IBM LTO-7 LTO-6 and LTO-7 ULTRIUM6, ULTRIUM6C,
ULTRIUM7, and ULTRIUM7C
7.1.3 and later
HP LTO-6, Quantum LTO-6, Tandberg LTO-6 LTO-5 and LTO-6 ULTRIUM5, ULTRIUM5C,
ULTRIUM6, and ULTRIUM6C
6.3.4 and later
HP LTO-7, Quantum LTO-7, LTO-6 and LTO-7 ULTRIUM6, ULTRIUM6C,
ULTRIUM7, and ULTRIUM7C
7.1.4 and later
Oracle T10000C Oracle T10000 T2 T10000C and T10000C-C 6.3.3 and later
Oracle T10000D Oracle T10000 T2 T10000D and T10000D-C 7.1.0 and later

Syntax:
>>-DEFine DEVclass--device_class_name--------------------------->

>--LIBRary--=--
library_name--DEVType--=--LTO-------------------->
    
   .-LBProtect--=--No------------.  
>--+-----------------------------+------------------------------>
   '-LBProtect--=--+-READWrite-+-'   
                   +-WRITEOnly-+                 
                   '-No--------'  


and

>>-UPDate DEVclass--device_class_name-------------------------->

>--+--------------------------+--------------------------------->
   '-LIBRary--=--
library_name-'   

>--+-----------------------------+------------------------------>
   '-LBProtect--=--+-READWrite-+-'   
                   +-WRITEOnly-+     
                   '-No--------'    
                       

LBProtect

Specifies whether logical block protection will be used to ensure the integrity of data stored on tape. The default is NO.

Possible values are:

READWrite

Specifies that logical block protection is enabled in the server and the tape drive for both read and write operations. Data is stored with CRC information in each block. This mode has performance impact because additional overhead is required for Tivoli Storage Manager and the tape drive to calculate and compare CRC values. This option does not affect backup sets and data that is generated by the BACKUP DB command.

When the LBProtect parameter is set to READWrite, you do not have to specify the CRCData parameter in a storage pool definition because logical block protection provides better protection against data corruption.

WRITEOnly

Specifies that logical block protection is enabled in the server and the tape drive for write operations only. Data is stored containing CRC information in each block. For read operations, the server and the tape drive will not validate the CRC. This mode affects performance because additional overhead is required for Tivoli Storage Manager and the tape drive to calculate and compare CRC values for write operations. This option does not affect backup sets and data that is generated by the BACKUP DB command.

No

Specifies that logical block protection is not enabled in the server and the tape drive for read and write operations. However, the server will enable logical block protection on write operations for a filling volume that already has data with logical block protection.

Firmware Requirements:

You must upgrade drive firmware to a revision that has logical block protection support. The following firmware revisions are recommended:

  • HP LTO-6 FH FC (Oracle STK Libraries) - firmware revision J2AS or later (validated with TSM 6.3.4)
  • HP LTO-6 HH FC (Oracle STK Libraries) - firmware revision 22GS or later (validated with TSM 6.3.4)
  • HP LTO-6 FH FC (Quantum Libraries) - firmware revision J2AZ or later (validated with TSM 6.3.4)
  • HP LTO-6 HH FC (Quantum Libraries) - firmware revision 22FZ or later (validated with TSM 6.3.4)
  • HP LTO-6 HH SAS (Quantum Libraries) - firmware revision 32CZ or later (validated with TSM 6.3.4)
  • HP LTO-6 FH FC (HP ESL G3) - firmware revision J38W or later (validated with TSM 6.3.4)
  • HP LTO-6 FH FC (HP EML E-Series)- firmware revision J38S or later (validated with TSM 6.3.4)
  • HP LTO-6 HH FC (HP MSL) - firmware revision 22FW or later (validated with TSM 6.3.4)
  • HP LTO-6 HH SAS (HP MSL) - firmware revision 32DW or later (validated with TSM 6.3.4)
  • HP LTO-7 FH FC (HP ESL G3) - firmware revision FA12 or later (validated with TSM 7.1.4)
  • HP LTO-7 HH FC & SAS (HP MSL) - firmware revision FA13 or later (validated with TSM 7.1.4)
  • IBM LTO-5 HH - firmware revision B6W9 or later
  • IBM LTO-5 FH - firmware revision BBN0 or later
  • IBM LTO-6 HH SAS - firmware revision C9T5 or later (validated with TSM 6.3.4)
  • IBM LTO-6 FH FC (Oracle STK Libraries) - firmware revision C9T4 or later (validated with TSM 6.3.4)
  • IBM LTO-6 FH FC (Quantum Libraries) - firmware revision CB20 or later (validated with TSM 6.3.4)
  • IBM LTO-7 FH FC (Quantum Libraries) - firmware revision FA10 or later (validated with TSM 7.1.4)
  • IBM TS1130 - firmware revision 27B0 or later
  • IBM TS1140 - firmware revision 35CD or later
  • IBM TS1150 - firmware revision 468E or later
  • IBM TS1070 & TS2370 - firmware revision F980 or later (validated with TSM 7.1.3)
  • Oracle T10000C - firmware revision 1.53 or later
  • Oracle T10000D - firmware revision 4.07 or later
  • Quantum LTO-6 HH SAS - firmware revision 4101 or later (validated with TSM 6.3.4)
  • Quantum LTO-7 HH SAS - firmware revision FA11 or later (validated with TSM 7.1.4)
  • Tandberg LTO-6 HH SAS - firmware revision 3249 or later (validated with TSM 6.3.4)

Device Driver Requirements (for IBM tape drives only):

IBM device drivers are available at Fix Central. The following IBM device driver version is required to use logical block protection:

  • AIX - version 12.4.9.0 or later
  • HP-UX - version 6.0.2.19 or later
  • Linux - version 1.58.0 or later
  • Solaris - version 4.2.2.0 or later for SPARC, version 4.2.6.1 or later for x64
  • Windows - version 6.2.1.8 or later, except version 6.2.2.x and 6.2.5.x

Related APARs:

  • IC78808 Logical Block Protection support
  • IC87520 AUDIT VOLUME MAY GET ANR9999D_2433840213 ILLEGAL BLOCK OFFSET FOR NTP VOLUME

Document information

More support for: Tivoli Storage Manager
Server

Software version: All Supported Versions

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Reference #: 1568108

Modified date: 03 November 2017