IBM Support

Unable to connect to a database because DB2 Connect license has expired

Troubleshooting


Problem

You getting message that the DB2 Connect license has expired when trying to connect to IBM DB2 Enterprise Server Edition database.

Symptom

The entry similar to following one may appear in the db2diag.log file:


2011-08-09-19.44.42.255249-300 XXX      LEVEL: Warning
PID     : 127404               TID  : 772         PROC : db2acd 4
INSTANCE: xxx             NODE : 004
EDUID   : 772                  EDUNAME: db2acd 4
FUNCTION: DB2 UDB, Health Monitor, HmonMainCB::refreshDbAutonomicSwitches, probe:160
MESSAGE : Failed connecting to database "XXX"
DATA #1 : Hexdump, 4 bytes
0x0000000110544DF4 : FFFF E0BF                                  ....

2011-08-09-19.44.42.259365-300 XXX     LEVEL: Error
PID     : 135782               TID  : 3299        PROC : db2sysc 4
INSTANCE: xxx             NODE : 004         DB   : XXX
APPHDL  : 4-30456              APPID: XXX
AUTHID  : xxxx
EDUID   : 3299                 EDUNAME: db2agent (XXX) 4
FUNCTION: DB2 UDB, license manager, sqllcConnectUser, probe:9
MESSAGE : ADM12024E  A valid license key was not found for the requested
          function.  The current license key for "DB2 Enterprise Server
          Edition" product does not allow the requested functionality. Purchase
          the license key for this function from your IBM representative or
          authorized dealer and update your license using the License Center or
          the db2licm command line utility. For more information on updating
          licenses refer to the Quick Beginnings manual for your platform. For
          more information on the db2licm utility, refer to the DB2 Command
          Reference.

Cause

The nodelock file containing license information might be corrupted.

Diagnosing The Problem

Please check that the DB2 Connect license has expired using the db2licm:

db2licm -l

You will see the list of available licenses similar to following one:

Product name:                     "InfoSphere Warehouse Enterprise Edition"
License type:                     "CPU"
Expiry date:                      "Permanent"
Product identifier:               "iwee"
Version information:              "9.5"

Product name:                     "DB2 Connect Server"
Expiry date:                      "Expired"
Product identifier:               "db2consv"
Version information:              "9.5"
Concurrent connect user policy:   "Disabled"
Enforcement policy:               "Soft Stop"

Try to remove expired license using the db2licm:

db2licm -r db2consv

Following error message indicates that the nodelock file has been corrupted:

LIC1417N The license specified could not be removed from the nodelock file. The return code is "-216". Check that the license for this product exists in the nodelock file.

Resolving The Problem

The problem can be resolved by re-creating the nodelock file:
  1. Back up the existing file:
    mv /license/nodelock /license/nodelock.bak
  2. Add the license once again so that nodelock file would be re-created:
    db2licm -a <path_to_license_file>
     
  3. Restart the instance and try to connect to a database once again.

Related Information

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Component":"Install\/Migrate\/Upgrade - Licensing","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"11.5;11.1;10.5;10.1;9.7;9.5","Edition":"Enterprise Server","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
05 July 2019

UID

swg21512232