IBM Support

Couldn't locate RRX code with IBM Datacap Taskmaster Capture

Troubleshooting


Problem

When running a task, an action aborts with an error indicating that an RRX could not be found.

Symptom

The RRS log will state:

error: couldn't locate RRX code '[library].rrx'

Cause

The logged RRX file could not be located by IBM Datacap Taskmaster Capture. This may especially occur when migrating from an earlier version of the product.

Resolving The Problem

Ensure that the RRX path logged by the action is a valid file path accessible by the account running the task. If the path is invalid, double-check the environment's configuration per the IBM Datacap Taskmaster Capture Installation and Configuration Guide Version 8.0.1.

When migrating from an earlier version of Taskmaster, any application specific RRX files will need to be modified to remove the ".rrx" extension from included library references. Edit the custom or application specific RRX file and modify XML <i> tags as needed.

Ex: <i ref="validations.rrx"/> becomes <i ref="validations"/>

In the example above, "validations.rrx" causes aborts when invoked because validations.rrx has been replaced with validations.dll in Taskmaster 8.0.1.

[{"Product":{"code":"SSZRWV","label":"IBM Datacap"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21499953