IBM Support

** Troubleshooting ** "Cannot create ActiveX component" (or ActiveX component can't create object) when running a Consolidation

Troubleshooting


Problem

User launches a consolidation. Looking inside the 'batch queue' user can see that the consolidation has not run successfully. Clicking on the 'details' section, there is an error message.

Symptom

The error may vary slightly depending on environments:

Controller 10.2 with batch queue enabled:

Cannot create ActiveX component

Controller 10.2 with batch queue disabled:


Some older versions of Controller:
ActiveX component can't create object

Cause

There are several possible causes for this error/problem:

Scenario #1 - (most likely) Missing (or incorrectly registered) components in the COM+ application (on the Controller application server):
  • frangovfp.main
  • frangovfp.cglobvar
This is caused by the DLL file "FrangoVFP.dll" not registering correctly during the installation procedure.
  • Typically the reason is because of a defect (reference APAR PH24802) in Controller 10.4.2 (and earlier versions) which causes the component not to be correctly installed on a brand-new application server.

Scenario #2 - (moderately likely) COM+ application
This has been seen with Controller 10.2. From this version onwards, for most environments the following settings are sufficient:

In some customer environments (very rare) these are insufficient.
  • TIP: For more details, see separate IBM Technote #1125903.

Scenario #3 - (moderately likely) Inaccessible required third-party components
Specifically, in some environments it may be necessary to copy the files "msvcr70.dll" and "msvcr71.dll" to a location inside the PATH variable, which all users have read access of.
 
Scenario #4 - (rare) Incorrect registry key permission(s)
  • Specifically, in one environment it was necessary to change the permission of the registry key 'HKCR\Wow6432Node\CLSID'.
  • For more details, see separate IBM Technote #1979305.
Scenario #5 - (rare) Unsupported IIS configuration
  • Specifically, the IIS virtual directories are configured to use a UNC path (\\server2\c$\program files\ibm\...) on the separate Controller application server
  • For more details, see separate IBM Technote #0888105.

Resolving The Problem

Scenario #1
Register the file 'frangovfp.dll' into the relevant COM+ application.
  • For more information, see separate IBM Technote #1347488.

Scenario #2

Example A: In one real-life customer example, add the group 'Everyone' to the list of 'COM+ users' inside the section 'Controller COM+ roles and users':
  • TIP: For more details, see separate IBM Technote #1125903.

Example B: In a different environment, it was necessary to also untick 'Enforce Access checks for the Controller COM+ application":


Scenario #3
The following steps are based on Controller 10.2.0 on Windows 2012. The steps may vary slightly for different versions/operating systems.
  • 1. Locate the folder 'server'.
    • TIP: By default this is located here: C:\Program Files\IBM\cognos\ccr_64\server

    2. Locate the following files:
    • msvcr70.dll
    • msvcr71.dll

    3. Copy both of those files into this folder: C:\Windows\system32
    4. Test.

    5. If the above does not solve the problem, then re-register the file 'frangovfp.dll' by following the steps inside Scenario #1.

Scenario #4
See separate IBM Technote #1979305.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"ARM Category":[{"code":"a8m0z000000GmwiAAC","label":"Consolidation"}],"ARM Case Number":"TS003903239","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
06 July 2020

UID

swg21459682