IBM Support

Knowledge Collection: Troubleshooting issues with Notes Basic 8.5.1.x clients disappearing and crashing without generating NSDs

News


Abstract

There are three known issues with Notes Basic 8.5.1.x clients intermittently disappearing, silently crashing, and terminating abnormally without generating an NSD. If you receive reports of this happening, review the symptoms and configurations listed below to assess which issue is applicable and identify the solution or workaround.

Content

If NSD is running as a service and the Notes data directory is stored on a file server...

  • If possible, move the data directory local to the workstation.
  • If after doing that NSDs are generated when a crash occurs, then the issue likely matches SPR TMDS84FRWM.
  • The solution for this issue is to store the data directory local on the user's workstation (or to the Citrix server, if applicable). However, if doing that is not an immediate option, you can work around the issue by disabling NSD from running as a service.

If the crash occurs specifically when hovering a mouse over Sametime icons in Notes Basic 8.5.1 FP1 or FP2...

  • Then the issue likely matches SPR DCHR844TKA, which is fixed in 8.5.1 Fix Pack 3.

If the symptoms and configurations described above are not applicable to your environment..

  • Then the issue is possibly related to SPR TMDS84VUHT, which is fixed in 8.5.1 Fix Pack 4 and 8.5.2.
  • To troubleshoot this issue, use WinDbg to collect a dump file (.dmp) and then send it to IBM Support for analysis. Steps provided below.

    1. Obtain and install Debugging Tools for Windows.

    2. Launch your Notes client.

    3. Launch the Microsoft debugger (Start -> Debugging Tools for Windows -> WinDbg).

    4. In WinDbg select File -> Attach to Process. A window will display listing all the current running processes. Select the nlnotes.exe process and click OK. If everything loaded properly then you should see a screen similar to the following:

    5. At this point the debugger is attached to the Lotus Notes process. To start the debugger, press the F5 key.


    6. Now the debugger is attached to the nlnotes.exe process and will monitor until a termination occurs.

    7. Click inside the command window. From the Edit menu, select Write Window to Text File. Name the file abnormal_termination.txt.

    8. Once the client terminates, select the Calls window.

    9. In the Calls window, click the Addrs button.

    10. From the Edit menu, select Write Window to Text File. Save to a file named callstack.txt. Also take a screenshot of the Calls window.

    11. Close the debugger.

    12. Close Notes.

    13. Notes client will not shutdown cleanly, so it will be necessary to either manually terminate the remaining Notes processes, or run an NSD -kill.

    14. Send abnormal_termination.txt, and callstack.txt in for analysis. See instructions in technote #1099524 - "Exchanging information with IBM Lotus Technical Support"

Related information

Troubleshooting Notes/Domino abnormal terminations on W
NSD will not run if started as OS service and Notes dat
Download options for Notes/Domino 8.5.1 Fix Packs
Track Notes/Domino Release Status

Document information

More support for: IBM Notes
Crash/Hang/NSD

Software version: 8.5.1, 8.5.1.1, 8.5.1.2, 8.5.1.3

Operating system(s): Windows

Software edition: All Editions

Reference #: 1438611

Modified date: 19 August 2010