IBM Support

"No current record" error returned updating/deleting a column with DATE/TIMESTAMP datatype in MS-Access using IBM DB2 ODBC driver.

Troubleshooting


Problem

When updating/deleting a Date/Timestamp column in MS-Access connecting to DB2 server using IBM DB2 ODBC driver, receive " No current record" error.

Symptom

Inserting/selecting the same data completes successfully. Issue only with Updating or Deleting the Date/Timestamp columns.

Cause

Due to MS-Access design, Timestamp/Date is being trimmed when updated from MS-Access which causes the issue.

Environment


Resolving The Problem


Set the following CLI parameters in DB2Cli.ini file to map Timestamp/Date values in the table to CHAR values when going through the CLI layer and relink the tables in MS-Access.

In your DB2Cli.ini file, manually add:

      [COMMON]
      MapTimeStampDescribe=1
      MapDateDescribe=1
      MapTimestampCDefault = 1

[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Programming Interface - ODBC","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.7;9.5;9.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21431243