Troubleshooting
Problem
When updating/deleting a Date/Timestamp column in MS-Access connecting to DB2 server using IBM DB2 ODBC driver, receive " No current record" error.
Symptom
Inserting/selecting the same data completes successfully. Issue only with Updating or Deleting the Date/Timestamp columns.
Cause
Due to MS-Access design, Timestamp/Date is being trimmed when updated from MS-Access which causes the issue.
Environment
Resolving The Problem
Set the following CLI parameters in DB2Cli.ini file to map Timestamp/Date values in the table to CHAR values when going through the CLI layer and relink the tables in MS-Access.
In your DB2Cli.ini file, manually add:
- [COMMON]
MapTimeStampDescribe=1
MapDateDescribe=1
MapTimestampCDefault = 1
Related Information
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Document Information
Modified date:
16 June 2018
UID
swg21431243