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DCOM got error "Logon failure: unknown user name or bad password. " and was unable to logon DOMAIN\USERNAME in order to run the server {EEB7EFB8...

Troubleshooting


Problem

User launches Controller. User receives error message. No users can logon to Controller. The system used to work OK in the past.

Symptom

Screen:

An error occurred while trying to access the server.

Event Viewer (Application Log):
DCOM got error "Logon failure: unknown user name or bad password. " and was unable to logon DOMAIN\USERNAME in order to run the server {EEB7EFB8...

Cause

There is a problem with the user account or password of the Windows user which is configured to run the Controller COM+ application.

Resolving The Problem



Steps:

  1. Ask the I.T. department's Windows domain administrator to check the user specified inside the error message (for example "Domain\username")
  2. Ensure that the user is not 'locked out' and the password is set to not expire
  3. Reset the password if this is not known
  4. Logon to the Controller application server as an administrator
  5. Ensure that the user (for example "Domain\username") is a member of the local "administrators" group on the application server
  6. Launch 'Controller Configuration' from the Start Menu
  7. Open the section 'COM+ Server'
  8. Check the value for the 'user' and change if necessary
  9. Check the value for the 'password' and change if necessary
  10. Press 'save' icon
  11. Reboot the Controller application server, and test.

IMPORTANT: If you are running a separate Consolidation Server, the "DCOM got error Logon failure: unknown user name or bad password." may NOT appear on logging into Controller and doing various tasks, but happens only when you are running a Consolidation.

If this is the case, you need to change the Consolidation server's COM+ password to match the one updated in steps 1-10 above.

See this TN for details:
Split ting the Controller COM+ to enable load-balancing of
consolidation VFP components across separate physical server

https://www-304.ibm.com/support/docview.wss?uid=swg21440369

To confirm is this is so, open the PDF doc at the foot of the above TN and go to page 19. Explore the Components Services on your own 'Consolidation server', do you see the same list of COM+ objects in the right hand panel? If so, can you use page 16 where it is shown how to set the password.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4","Edition":"Edition Independent","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21429662