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** Troubleshooting ** 'Controller Configuration' hangs when selecting 'Report Server'

Troubleshooting


Problem

I.T. administrator logs onto the application server, and launches "Controller Configuration". Administrator clicks on the section "Report Server". The 'Controller Configuration' application hangs (not responding).

Symptom

Controller Configuration turns grey when opening (or saving changes in) Report Server section:

In some cases a message is displayed before the application hang (however, this message is often normal for new installations):


    Registry and Web.Config settings are not syncronized.

    Open the Report Server section and resave the settings to repair this.

Cause

There is not a value report server (which is working OK, and can respond) running on the URL that is specified inside 'Report Server'.

There are several different potential causes for this:

  • Scenario #1 - The relevant report server has a problem (for example is down/switched-off)
  • Scenario #2 - Misconfiguration (for example a typo mistake) where the 'wrong' name for the server website has been previously typed into the Report Server section
    • These settings are stored inside the registry ("CRNPath") and also inside a file ("Web.Config")
    • If these values are invalid, it will not be possible to open the section "Report Server" (insude the GUI) to repair them.

Resolving The Problem

Scenario #1 - Report server is not running

Bring the relevant report server (the one mentioned inside the 'Report Server' section) online.


Scenario #2 - Misconfiguration (for example a typo mistake)
Manually modify the 'Web.Config' file, to change the "crnServer" and "crnDisp" settings to the correct (intended) value.

Steps:
1. Logon to the Controller application server
2. Browse to the following folder: ControllerProxyServer
  • TIP: By default, for Controller 10.2.1 this is here: C:\Program Files\ibm\cognos\ccr_64\ControllerProxyServer

3. As a precaution, create a backup copy of the file: web.config

4. Edit (for example inside 'Notepad') the file: web.config
5. Search for a section similar to:

<add key="crnServer" value="http://BAD_SERVER_NAME/ibmcognos/cgi-bin/cognos.cgi" />
<add key="crnDisp" value="http://VBRACONT8AP2:9300/p2pd/servlet/dispatch" />

6. Modify the values to the correct (intended) settings
7. Save changes
8. Test.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3.1;10.3;10.2.1;10.2.0;10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
23 June 2018

UID

swg21408831