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Controller client does not launch on 64-bit operating system - blank/white screen and/or error "Microsoft IE Execute shell ... EventType clr20r3, P1 ieexec.exe ...P9 system.badimageformatexception")

Troubleshooting


Problem

User launches Cognos Connection (for example http://servername/cognos8). User clicks 'Consolidate my financial information' to launch Controller. Alternatively, use launches direct link (for example ) to Controller client. Controller does not launch. There is an error recorded inside the client device's Application Log (inside Microsoft Event Viewer).

Symptom


Different error(s) will be recorded, depending on the environment. Below are some examples:

Example #1

Event Type: Error
Event Source: .NET Runtime 2.0 Error Reporting
Event Category: None
Event ID: 5000
Date: 24/08/2009
Time: 11:30:41
User: N/A
Computer: CLIENTDEVICE
Description:
EventType clr20r3, P1 ieexec.exe, P2 2.0.50727.1433, P3 471eb911, P4 ieexec, P5 2.0.0.0, P6 471eb911, P7 9, P8 116, P9 system.badimageformatexception, P10 NIL.

Example #2

Screen:

Microsoft IE Execute shell
Microsoft IE Execute shell has encountered a problem and needs to close.
We are sorry for the inconvenience.

Application log:

Event Type: Error
Event Source: .NET Runtime 2.0 Error Reporting
Event Category: None
Event ID: 5000
Date: 02/09/2009
Time: 04:36:26
User: N/A
Computer: CLIENTDEVICE
Description:
EventType clr20r3, P1 ieexec.exe, P2 2.0.50727.1433, P3 471ebc85, P4 mscorlib, P5 2.0.0.0, P6 471eb8e7, P7 3aa0, P8 37, P9 exception, P10 NIL.

Example #3 (Windows 7 64-bit)

Microsoft IE Execute shell
Microsoft IE Execute shell has stopped working
A problem caused the program to stop working correctly.
Please close the program.
-> Close the program.

Cause

TIP: There are many different potential causes for similar symptoms. For more examples, see separate IBM Technote #1347103.

This IBM Technote specifically relates to the scenario where the client device is running a 64-bit operating system.

  • By default, this will try to run 32-bit code (downloaded from a website) as 64-bit.
  • However, Controller code is entirely 32-bit, so the software will crash.

Environment

Controller client (CCR.EXE) running on 64-bit version of Windows (e.g. Windows 7 64-bit or Windows 2008 R2).

Resolving The Problem

There are two different potential solutions:

  • Method #1 - (Recommended method) Run the Controller client locally.
    • In other words, run CCR.EXE directly from a folder on client device's hard drive (rather than directly from website)
    • In other words, install the local Controller client ("CCRLocalClient.MSI") on the client device, and use this (instead of running the Controller client from the website http://server/ibmcognos/controllerbin/ccr.exe)
    • This is the author's preferred/recommended method of client deployment for most customers.

    Method #2 (only to be used in some operating systems/circumstances) - Modify the 64-bit client device (for example Windows 2003 64-bit Citrix/Terminal Server) to automatically run *all* website's .NET code as 32 bit

    • NOTE: Do not use this method to try to get the Controller client to run on the Controller application server itself. This can cause other issues (for example see separate Technotes #1673225 & 1668455).
    • Also, feedback suggests that this also should not be used if using Windows 2012 server as your client operating system.

    Method #3 - (NOT recommended/supported) Modify Microsoft's .NET file 'ieexec.exe' to run as 32-bit.

    WARNING: This is not supported by Microsoft. Use this method at your own risk.

    • See separate Technote 1570390 for more details.

Steps:

Method #1 - Run the Controller client locally (Recommended method)

Either:

(a) Instead of installing the 'standard' Controller Excel link ("ControllerClient.Msi") install the local client version ("CCRLocalClient.Msi").

  • This is the author's recommended method
  • TIP: See separate IBM Technote 1371088 for more information.

or (b) Manually copy the files over, by performing the following steps:
  1. Logon to Controller webserver as an administrator
  2. Locate the CCR folder (TIP: By default, this is C:\Program Files\Cognos\c8\webcontent\ccr)
  3. Copy the entire CCR folder (and contents) to the client device (for example copy to the folder C:\Program Files\Cognos\Controller\local\CCR)
  4. Create a shortcut to the CCR.EXE file for the end user(s). For example, create shortcut to C:\Program Files\Cognos\Controller\local\CCR\ccr.exe
  5. Test.

Method #2 - Modify the 64-bit client device (for example Windows 2003 64-bit Citrix/Terminal Server) to automatically run *all* website's .NET code as 32 bit

NOTE:

  • Do not use this method to try to get the Controller client to run on the Controller application server itself. This can cause other issues (for example see separate Technotes #1673225 & 1668455).
  • Also, feedback suggests that this also should not be used if using Windows 2012 server as your client operating system.

1. Logon to the 64-bit (operating system) client device as a Windows administrator

2. Click "Start - All Programs - Accessories"

3. Right-click on "Command Prompt" and choose "Run as administrator":


4. If prompted, click "yes" to confirm:



5. Type the following (to change the directory)


    cd C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\

5. Type the following:


    Ldr64.exe setwow

This will disable the "COMPLUS_ENABLE_64BIT" flag and cause *all* .NET code to run as 32-bit on this 64-bit client device.

TIP: If you want to make the above process slightly easier, then you can instead:

  • Download the attached batch file ("1398266_disable_64-bit_complus.bat")
  • Logon to the client device as a Windows administrator
  • Right-click on the file and choose "Run as administrator:"

Method #3 - (NOT recommended/supported)

WARNING: This is not supported by Microsoft. Use this method at your own risk.

  • See separate Technote 1570390 for more details.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.0;10.1.1;10.1;8.5.1;8.5","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21398266