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V9 DB2 Connect installation on Windows fail with error 2896.

Technote (troubleshooting)


Problem(Abstract)

V9 DB2 connect installation on Windows fail with following messages in installation log:

Action start 10:29:40: set_INSTALL_NAME_AND_SELECT_propertyCA.
Action ended 10:29:40: set_INSTALL_NAME_AND_SELECT_propertyCA. Return value 3.
DEBUG: Error 2896: Executing action set_INSTALL_NAME_AND_SELECT_propertyCA failed.
Internal Error 2896. set_INSTALL_NAME_AND_SELECT_propertyCA
Action ended 10:29:40: InstallWelcome. Return value 3.
Action 10:29:40: SetupCompleteError.
Action start 10:29:40: SetupCompleteError.
Action 10:29:40: SetupCompleteError. Dialog created

Cause

The issue could be due to the previously uninstalled V9 DB2 product not being completely cleaned up.

Resolving the problem

Clean the previous DB2 V9 installation using db2unins -f and try installing again.

-f option:
Performs a brute force uninstallation of ALL DB2 database products on the system. The db2unins -f command can be issued from either the installation media or an install copy on your machine. Your system will reboot when you successfully issue db2unins -f. It can only be issued if there are no DB2 products prior to version 9 installed on the system.

So use the -f option only if the above conditions are met.

Related information

db2unins
V8 Uninstall

Document information

More support for: DB2 for Linux, UNIX and Windows
Connectivity - Other

Software version: 9.1, 9.5

Operating system(s): Windows

Reference #: 1382891

Modified date: 23 April 2009


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