IBM Support

Error 'There is a problem with this Windows Installer package...' launching Controller 8.x

Troubleshooting


Problem

User launches Controller for the first time. The Controller Excel link attempts to install. User receives error message. Similar error messages occur if the administrator attempts to manually install the Controller Excel link client directly (for example by double-clicking on 'ControllerClient.MSI', 'ClientAdmin.MSI' or 'CCRLocalClient.MSI').

Symptom

Screen message:

There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor.

Event Viewer (Application Log) on client device:

In addition you will find an event in the Windows Event log, similar to the following:

Controller 8.1.x:

Event Type: Error
Event Source: MsiInstaller
Event Category: None
Event ID: 11720
Date: 2006-04-12
Time: 15:23:26
User: DOMAIN\username
Computer: PCNAME
Description:
Product: Cognos Controller Client -- Error 1720. There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom action CognosUnregisterComponents script error -2147024894, : Line 8, Column 1,

Controller 8.4.x



Event Type: Error
Event Source: MsiInstaller
Event Category: None
Event ID: 11720
Date: 2009-04-12
Time: 15:23:26
User: DOMAIN\username
Computer: PCNAME
Description:
Product: IBM Cognos 8 Controller Link Add-in -- Error 1720. There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom action CognosUnregisterComponents script error -2147024894, : Line 7, Column 1,

Cause

There are several different potential causes for the error 'There is a problem with this Windows Installer package'.

  • For more examples, see separate IBM Technote #1345359.

However, this IBM Technote specifically relates to the scenario where the client PC has the incorrect version of Microsoft .NET Framework installed.

Resolving The Problem

Install the appropriate version of Microsoft .NET Framework before installing the Controller Excel link client.

TIP: Different versions of Controller 8.x require different versions of Microsoft .NET Framework.

  • Controller 8.1.x requires Microsoft .NET 1.1 *plus* the additional Service Pack 1 installed as well
  • Controller 8.2.x, 8.3.x and 8.4.x requires .NET 2.0 service pack 1

Steps:

Controller 8.1.x:

  • Logon to the client PC
  • Download (from Microsoft) Microsoft .NET Framework 1.1
    • Double-click on the file 'dotnetfx.exe'
  • Afterwards, download (from Microsoft) .NET Framework 1.1 SP1
    • Double-click on the file 'NDP1.1sp1-KB867460-X86.exe'

Controller 8.2.x, 8.3.x and 8.4.x:

  • Logon to the client PC
  • Download (from Microsoft) Microsoft .NET Framework 2.0 SP1
    • Double-click on the file 'NetFx20SP1_x86.exe'

TIP: For more information on Controller client best practices, search the IBM Cognos Proven Practice documentation website here: http://www.ibm.com/developerworks/data/library/cognos/cognosprovenpractices.html

For example, the proven practice Controller 8.4.x client installation guide is currently located here:
http://www.ibm.com/developerworks/data/library/cognos/page246.html

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4;8.3;8.2;8.1","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1019068

Document Information

Modified date:
15 June 2018

UID

swg21382295