IBM Support

MustGather: Enable debugging for ClearCase and ClearQuest installs using Installation Manager

Question & Answer


Question

How can I enable debugging for IBM Rational ClearCase and IBM Rational ClearQuest installations using Installation Manager?

Cause


Certain situations can sometimes cause the installation of ClearCase or ClearQuest to fail. If the information provided in the log files is not enough to solve the problem, turning on debugging can help further narrow down the problem.

Answer

Debugging can be turned on either after Installation Manager is installed or before if you are having problems installing Installation Manager itself.

Enable Debugging

Turning on debugging once Installation Manager is installed:

  • cd to the logs directory:
    • UNIX/Linux: cd /var/ibm/InstallationManager/logs
    • Windows: C:\ProgramData\IBM\Installation Manager\logs
      (older): C:\Documents and Settings\All Users\Application Data\IBM\Installation Manager\logs

Note: The ProgramData folder is most likely hidden and you will have to unhide to see its contents. 

Windows File Explorer:

image-20220907114733-1

  • Create a file named log.properties and add the following lines:

    com.ibm.cic.agent.core.Engine=DEBUG
    InstallOrderManager=DEBUG
    InstallOperation=DEBUG
    MetadataReplacer=DEBUG


    If you are using Installation Manager 1.3.3 or higher and the install has already failed, add this line to the above file:
    InstallOperation/pause.on_error=true

    This will pause the install at the time of the error and allow the user to collect any log files that were mentioned in the original failure that were deleted when the install rolled back. Of interest would be logs such as:

    /opt/rational/common/eWAS/logs
    /opt/rational/common/CM/profiles/cmprofile/logs
    /opt/rational/common/IHS/logs
    • Warning: If adding the line "InstallOperation/pause.on_error=true", Installation Manager has to be executed from a command line because it will require user intervention to resume the install process.
      You will need to press enter (after collecting the additional log files) to allow the install to properly fail.

      Failure to do so will require to kill IM process and it will leave the installation in an uncompleted state. To solve this you will need to uninstall the product and perform a manual clean up.

      To execute IM from a command line:
      Windows: "Program Files\IBM\Installation Manager\eclipse\IBMIMc.exe"
      Unix: "/opt/IBM/InstallationManager/eclipse/IBMIM"
  • Save the file
  • Now invoke Installation Manager from a command line and repeat the install that is having problems.

    The debug information will be written to the log file in:
    • Windows: C:\ProgramData\IBM\Installation Manager\logs\<date_time>.xml
      (older): C:\Documents and Settings\All Users\Application Data\IBM\Installation Manager\logs\<date_time>.xml
    • UNIX/Linux: /var/ibm/InstallationManager/logs/<date_time>.xml
      In addition, the debug information will also be written to the terminal window that Installation Manager was invoked from. The information in the terminal window can be ignored as it is also written to the log file.
    • If the debug information does not help you solve the issue, send the following data to IBM Rational Client Support for further analysis.

      Zip up the contents of the entire Installation Manager agent data:
      • Windows : C:\ProgramData\IBM\Installation Manager\
        (older): C:\Documents and Settings\All Users\Application Data\IBM\Installation Manager\
      • UNIX/Linux: tar up the contents of /var/ibm/InstallationManager/

Note: If you are having problems with the installation of the Installation Manager itself, you can still create the log.properties file as noted above, however, you will need to carefully create the directories to put the file in (as they do not exist within a pre-install state). You can issue a mkdir -p /var/ibm/InstallationManager/logs  command to generate the directories necessary to create the log.properties file, and thus debug the install of the Installation Manager, if necessary.

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSSH27","label":"Rational ClearCase"},"ARM Category":[{"code":"a8m0z000000bo4qAAA","label":"ClearCase-\u003EInstallation\/Upgrade"}],"ARM Case Number":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.0.1;9.0.2;9.1.0"},{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"ARM Category":[{"code":"a8m0z000000boPyAAI","label":"ClearQuest-\u003EInstallation\/Upgrade"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.0.1;9.0.2;9.1.0"}]

Document Information

Modified date:
27 September 2022

UID

swg21358628