Troubleshooting
Problem
Symptom
Example - Controller 10.2.1:
The IBM Cognos gateway is unable to connect to the IBM Cognos BI server. The server may be unavailable or the gateway may not be correctly configured.
Try again or contact your administrator.
Example - older version:
The IBM Cognos gateway is unable to connect to the IBM BI server. The server may be unavailable or the gateway may not be correctly configured.
Try again or contact your administrator.
Cause
- The Gateway server's cryptographic keys are out-of-synch with the content manager server
- See separate IBM Technote #299795
- Or (rare) Cognos BI server's Microsoft IIS website has a problem, and requires an IISRESET
- See separate IBM Technote #794459.
Examples:
There are several potential causes for the IBM Cognos service not starting correctly:
- For example, the SQL server could have been off-line during the period of time that the report server (application server) was starting up. This caused the 'IBM Cognos' service to be unable to use the configured 'content store' database.
TIP: When rebooting Controller servers, reboot the database (for example SQL) server first, and then reboot the Controller application server afterwards. This is to ensure that the content store database is available when the application server starts the Cognos BI report service.
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- For example, the SQL server may have a problem (such as the hard drive is full)
The 'IBM Cognos' reporting service, is configured inside the application 'Cognos Configuration'.
- By default, the service will register itself as a Windows service, and will start automatically when the server reboots.
- However, it can be manually started/restarted from inside 'Cognos Configuration' (launched from the Start Menu).
If you have multiple Controller application servers, there will typically be one 'Report Server' - this is the one application server which runs this Windows service.
- By design, the other application servers will typically not have this service running
Diagnosing The Problem
- Open the log file 'cogserver.log' ( <install location>\logs\cogserver.log)
- Look for an error message similar to:
CM-SYS-5003 Content Manager is unable to access the content store. Verify your database connection parameters and then contact your database administrator.
Failed Logon:com.jnetdirect.jsql.g: TCP/IP connection failed to host:dbserver java.net.ConnectException: Connection timed out: connect jdbc:JSQLConnect://dbserver:1433/controllerreports">url:jdbc:JSQLConnect://dbserver:1433/controllerreports
Resolving The Problem
Configure 'Cognos Configuration' correctly (in particular, the 'Report Server' and 'Dispatcher URI' setting), then restart service.
Ensure the SQL database server is online (available), and the 'content store' database is available and valid. Afterwards, restart application server(s) (report server in particular), and test.
Long term fix:
When rebooting Controller servers, reboot the database (for example SQL) server first, and then reboot the Controller application server afterwards. This is to ensure that the content store database is available when the application server starts the Cognos BI report service.
Example #3 - Cognos BI Report Server's database repository ("the contentstore") has a problem
- Logon to the 'report server' as an administrator
- Launch 'IBM Cognos Configuration' (known as 'Cognos Configuration' in earlier releases)
- Expand 'Local Configuration - Data Access - Content Manager'
- Right-click on 'Content Store'
- Click 'test'
- Make a note of any error message and diagnose using IBM Technotes.
TIP: For example:
Example #4 - System used to work OK, but suddenly stopped working with no apparent explanation
Upgrade to a modern version of Controller.
Workaround:
Start (or re-start) the 'IBM Cognos' Windows service, and/or reboot the entire report server itself.
- For more details, see separate IBM Technote #1347144.
Related Information
1340234 - The Cognos Gateway is unable to connect to th
1347377 - Cognos 8 Windows service does not start autom
1347527 - Cannot start Cognos 8 Service after upgrading
1347144 - Cannot run a standard report
0794459 - 'The Cognos Gateway is unable to connect to the Cognos BI server' wh…
299795 - "The IBM Cognos gateway is unable to connect to the IBM Cognos BI serv…
Historical Number
1040002
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Document Information
Modified date:
21 July 2020
UID
swg21347919