Troubleshooting
Problem
The IBM Cognos report Windows service does not start even though everything appears to be installed properly and all the checks in Cognos Configuration pass OK.
Symptom
Cognos 10:
CFG-ERR-0106 IBM Cognos Configuration did not receive a response from the IBM Cognos service in the time allotted
Cause
There are several possible causes for this message.
- TIP: For more examples, search for CFG-ERR-0106 or refer to the Related Information section below.
This document specifically relates to the scenario whereby the cause is that the JAVA_HOME Windows System Environment Variable is not set correctly.
Diagnosing The Problem
Inside 'Task Manager' ensure that "Show processes from all users" is ticked. Then look for a process called 'java.exe'. If it does not exist and, therefore, not running, this is an indication that it may indeed be the issue.
Resolving The Problem
Generally, the JAVA_HOME variable does not need to be set for IBM Cognos to function.
- However, in some rare instances, it is necessary to have JAVA_HOME set to a file system location, for example, if another non-Cognos application on the machine requires it.
When using 64-bit versions of Windows, by default, this would be:
- Cognos10.2.2 C:\Program Files\ibm\cognos\c10_64\bin\jre\7.0
Steps:
1. Right Click on My Computer and select Properties from the menu
2. Click on the Advanced tab
3. Click on the Environment Variables button
4. Check the JAVA_HOME environment variable in the System variables section to ensure the JAVA path is correct.
- For recent versions of Cognos products it is usually best to delete the variable 'JAVA_HOME' so that it does not exist
- However, for some systems it is still necessary to create and use this variable.
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21342592