IBM Support

B37-04 error scanning JCL

Troubleshooting


Problem

When scanning JCL in IBM WebSphere Studio Asset Analyzer, B37-04 errors are reported.

Cause

B37-04 is a space issue, specifically with the temporary file space used by the EXIT processing in the DMH610Z routine. DMH610Z is used to create a list of libraries and members which are to be analyzed and loaded in the database. The code in DMH610Z that allocates it is:


/* This ALLOCATION is about 40,000 files per container, as 500 */
/* files fit in 1 track: ((5 + (5 * 15)) * 500) = 40,000 */

"ALLOC FI(FILELIST) DA('"ssParmFile"') NEW CATALOG TRACKS SPACE(5,5) LRECL(80) RECFM(F,B) DSORG(PS)"

The space is set up for 40,000 files so the B37-04 means you have run out of extents (only allowed 16).

Resolving The Problem

Change the space allocation by editing yourHLQ.SDMHREXX(DMH610Z) and increasing the space allocation in the code shown above.

[{"Product":{"code":"SSXJB2","label":"WebSphere Studio Asset Analyzer"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Inventory scan","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"4.1","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Document Information

Modified date:
16 June 2018

UID

swg21227089