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clearviewtool/xdr/albd: Error: Unable to contact albd_server

Troubleshooting


Problem

This technote identifies the errors related to the attempts around creating an IBM Rational ClearCase view on Microsoft Windows where the ALBD service is not running.

Symptom

Attempts to create a view while the ALBD is stopped results in the following errors:


Error #1

clearviewtool/xdr/albd: Error:  Unable to contact albd_server on (local host)
clearviewtool/view: Error:  unable to find albd
clearviewtool/cmd: Error: unable to create view "<unc to view storage path>"


Error #2


albd_contact call failed: RPC: Unable to receive; errno = [WINSOCK] Connection reset by peer
cleartool: Error: Unable to contact albd_server on host 'HOST1'
cleartool: Error: Operation "rgy_findbyuuid_entry" failed: timed out trying to communicate with ClearCase remote server.
albd_contact call failed: RPC: Unable to receive; errno = [WINSOCK] Connection reset by peer
cleartool: Error: Unable to contact albd_server on host 'HOST1'
cleartool: Error: No available Server Storage Location entries.

Cause

This error appears when the ALBD service is not started on the machine where the view is being created.


Resolving The Problem

Start the ALBD service on the view server and repeat view creation process.

Review technote 1134178 for details on how to start and stop ClearCase from the Windows command line.

  1. Open the ClearCase Control Panel (Start > Run type cc.cpl)
  2. Click the Services Startup tab
  3. Click Start ClearCase






[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ALBD","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2002.05.00;2003.06.00;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21148929