IBM Support

PM91863: RIT 8.5 STUB LOOSES XML MESSAGE BODY WHEN RE-APPLYING SCHEMA (INCLUDING PLAIN XML SCHEMA)

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • RIT 8.5 Stub looses XML message body when re-applying schema
    (including plain XML schema)
    
    This happens when the stub has an XML body, but the editor does
    not indicate that a schema has been applied.  Subsequently if a
    schema is applied and the stub editor (or test editor) is closed
    and re-opened the XML will no longer be present.
    

Local fix

  • There is a work around which is to apply the schema before
    loading in the XML.   This means that the XML must be loaded in
    from the field editor so the workaround may not be obvious to
    clients, even where they realize that the XML vanishes when the
    schema is applied and the stub closed and re-opened.
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * All users of Rational Integration Tester                     *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * Where XML is set up in the first child of a message and a    *
    * schema is then applied the XML message is lost where the     *
    * schema applied was not previously known (as indicated by the *
    * presence of text such as {XML} or {XML Schema} or {SOAP      *
    * Message} after the XML root node).  It is not apparent that  *
    * the XML has been removed until after the stub is closed and  *
    * re-opened.                                                   *
    *                                                              *
    * This problem becomes more likely to occur when XML is        *
    * imported into the message action using the "[right click]    *
    * Contents > XML > Import XML" functionality but no schema is  *
    * applied.  Because of the problem described above  the user   *
    * cannot then manually apply a schema without losing the XML   *
    * contents.  By contrast this problem does not typically       *
    * happen with the "Open Field Value..." functionality from the *
    * field editor, because it will typically be used after the    *
    * schema has been applied.                                     *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Upgrade to Rational Integration Tester 8.5.0.1               *
    ****************************************************************
    

Problem conclusion

  • This problem was resolved in Rational Integration Tester 8.5.0.1
    

Temporary fix

Comments

APAR Information

  • APAR number

    PM91863

  • Reported component name

    RATL TEST WORKB

  • Reported component ID

    5725G7900

  • Reported release

    850

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2013-06-26

  • Closed date

    2014-01-14

  • Last modified date

    2014-01-14

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    RATL TEST WORKB

  • Fixed component ID

    5725G7900

Applicable component levels

  • R800 PSN

       UP

  • R801 PSN

       UP

  • R850 PSY

       UP



Document information

More support for: Rational Test Workbench

Software version: 8.5

Reference #: PM91863

Modified date: 14 January 2014