IBM Support

PI74494: IBM RATIONAL DEVELOPER FOR Z (RDZ) HCE DOES NOT SUPPORT TLS 1.2

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • IBM Rational Developer for z (RDz / IDz) Host Connection
    Emulator (HCE) does not support TLS 1.2 with MS-CAPI
    
    When you select to connect using HCE you have the option of
    choosing SSL > TLS.
    
    The two sides then negotiate the version to use for the session
    and the supported ciphers.
    
    The underlying code used by the HCE does not provide TLS 1.2
    with MS-CAPI.
    

Local fix

Problem summary

  • See error description.
    

Problem conclusion

Temporary fix

Comments

APAR Information

  • APAR number

    PI74494

  • Reported component name

    DEV FOR Z SYS

  • Reported component ID

    5724T0700

  • Reported release

    951

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2017-01-06

  • Closed date

    2017-11-30

  • Last modified date

    2017-11-30

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    DEV FOR Z SYS

  • Fixed component ID

    5724T0700

Applicable component levels

  • R951 PSY

       UP



Document information

More support for: Rational Developer for System z

Software version: 951

Reference #: PI74494

Modified date: 30 November 2017