IBM Support

PI46445: TM1 ARCHITECT "DATA SPREAD FAILED" ERROR WHEN ENTERING A NUMERIC VALUE

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

APAR status

  • Closed as program error.

Error description

  • TM1 Architect "Data Spread failed" error when entering a numeric
    value in the elementAttribute_mth_list control  cube on TM1
    10.2.2 FP3 IF1 when same rules worked in TM1 10.2.2 IF1.
    
    Just enter any numeric value in the elementAttribute_mth_list
    control cube and hit enter.  If rules are commented out, error
    is not displayed.  Xavier Osorio has already been in contact
    with David Corbett  in ProdMan.  Model and screenshot attached.
    
    Rules such as the one below work in TM1 10.2.2 IF1, but stop
    working
    when this model is moved to TM1 10.2.2. FP3
    
    ['start_Flag' ]= IF(DB('Depreciation Control', 'Default
    Baseline',
    'Fiscal Period Start')@=
    DIMNM('Mth_list',dimix('Mth_list',!Mth_list)),1,0);
    ['Jan','mth_position']=IF(DB('}ElementAttributes_Mth_list',
    'Jan',
    'start_Flag')=1,1,
    IF(DB('}ElementAttributes_Mth_list', 'Feb', 'start_Flag')=1,12,
      IF(DB('}ElementAttributes_Mth_list', 'Mar',
    'start_Flag')=1,11,
       IF(DB('}ElementAttributes_Mth_list', 'Apr',
    'start_Flag')=1,10,
        IF(DB('}ElementAttributes_Mth_list', 'May',
    'start_Flag')=1,9,
         IF(DB('}ElementAttributes_Mth_list', 'Jun',
    'start_Flag')=1,8,
          IF(DB('}ElementAttributes_Mth_list', 'Jul',
    'start_Flag')=1,7,
           IF(DB('}ElementAttributes_Mth_list', 'Aug',
    'start_Flag')=1,6,
            IF(DB('}ElementAttributes_Mth_list', 'Sep',
    'start_Flag')=1,5,
             IF(DB('}ElementAttributes_Mth_list', 'Oct',
    'start_Flag')=1,4,
              IF(DB('}ElementAttributes_Mth_list', 'Nov',
    'start_Flag')=1,3,
               IF(DB('}ElementAttributes_Mth_list', 'Dec',
    'start_Flag')=1,
    2,0
               )
              )
             )
            )
           )
          )
         )
        )
       )
      )
    )
    );
    
    All of the rules for cube "}ElementAttributes_Mth_list" have
    stopped
    working on FP3.
    

Local fix

  • TM1 Architect "Data Spread failed" error when entering a numeric
    value in the elementAttribute_mth_list control  cube on TM1
    10.2.2 FP3 IF1 when same rules worked in TM1 10.2.2 IF1.
    
    Just enter any numeric value in the elementAttribute_mth_list
    control cube and hit enter.  If rules are commented out, error
    is not displayed.  Xavier Osorio has already been in contact
    with David Corbett  in ProdMan.  Model and screenshot attached.
    
    Rules such as the one below work in TM1 10.2.2 IF1, but stop
    working
    when this model is moved to TM1 10.2.2. FP3
    
    ['start_Flag' ]= IF(DB('Depreciation Control', 'Default
    Baseline',
    'Fiscal Period Start')@=
    DIMNM('Mth_list',dimix('Mth_list',!Mth_list)),1,0);
    ['Jan','mth_position']=IF(DB('}ElementAttributes_Mth_list',
    'Jan',
    'start_Flag')=1,1,
    IF(DB('}ElementAttributes_Mth_list', 'Feb', 'start_Flag')=1,12,
      IF(DB('}ElementAttributes_Mth_list', 'Mar',
    'start_Flag')=1,11,
       IF(DB('}ElementAttributes_Mth_list', 'Apr',
    'start_Flag')=1,10,
        IF(DB('}ElementAttributes_Mth_list', 'May',
    'start_Flag')=1,9,
         IF(DB('}ElementAttributes_Mth_list', 'Jun',
    'start_Flag')=1,8,
          IF(DB('}ElementAttributes_Mth_list', 'Jul',
    'start_Flag')=1,7,
           IF(DB('}ElementAttributes_Mth_list', 'Aug',
    'start_Flag')=1,6,
            IF(DB('}ElementAttributes_Mth_list', 'Sep',
    'start_Flag')=1,5,
             IF(DB('}ElementAttributes_Mth_list', 'Oct',
    'start_Flag')=1,4,
              IF(DB('}ElementAttributes_Mth_list', 'Nov',
    'start_Flag')=1,3,
               IF(DB('}ElementAttributes_Mth_list', 'Dec',
    'start_Flag')=1,
    2,0
               )
              )
             )
            )
           )
          )
         )
        )
       )
      )
    )
    );
    
    All of the rules for cube "}ElementAttributes_Mth_list" have
    stopped
    working on FP3.
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * All Users                                                    *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * See error description.                                       *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Upgrade to IBM Cognos TM1 10.2.2 Fix Pack 5                  *
    ****************************************************************
    

Problem conclusion

  • Code Fix
    

Temporary fix

Comments

APAR Information

  • APAR number

    PI46445

  • Reported component name

    TM1 SERVER

  • Reported component ID

    5724W49SE

  • Reported release

    A22

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2015-08-06

  • Closed date

    2016-03-04

  • Last modified date

    2016-03-04

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    TM1 SERVER

  • Fixed component ID

    5724W49SE

Applicable component levels

  • RA22 PSN

       UP



Document information

More support for: Cognos TM1
TM1 Server

Software version: A22

Reference #: PI46445

Modified date: 04 March 2016