IBM Support

PI19295: PERFORMANCE MODELER 10.2.2 ADDING A USER IN SECURITY MODE 1 GENERATES AN ERROR

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

APAR status

  • Closed as program error.

Error description

  • Adding user to a cube, using Connect Directly button on
    Performance Modeler application    Process to replicate problem
    in Windows 2008 r2  1) Start  2) IBM Cognos TM1 Performance
    Modeler  3) Connect to IBM Cognos TM1 System  3a) System URL
    http://localhost:9510/pmpsvc/services  4) Click Connect Directly
    button  4a) Username & password  4b) click ok  5) Right click
    (in Model design area) localhost:Planning Sample  5a) Configure
    Security  5b) Define Users and groups  5c) Users and Groups  6)
    Click on icon for add user    Error message    The error message
    reads ...    There was an internal application problem. Try to
    save your work and exit the application.  [CCLMsg: system
    text='You must set a planning service URL before retrieving the
    planning service.']      Opening up the details box, in the
    error dialog box, the following text is displayed
    com.ibm.cognos.pmpsvc.util.PlanningServiceHolder.getPlanningServ
    ice(PlanningServiceHolder.java:180)
     com.ibm.mdt.widgets.cube.actions.AddUserAction.run(AddUserActio
    n.java:63)
     org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
    org.eclipse.jface.action.ActionContributionItem.handleWidgetSele
    ction(ActionContributionItem.java:584)
     org.eclipse.jface.action.ActionContributionItem.access$2(Action
    ContributionItem.java:501)
     org.eclipse.jface.action.ActionContributionItem$6.handleEvent(A
    ctionContributionItem.java:452)
     org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84
    )
     org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
    org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4
    169)
     org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:37
    58)
     org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2
    701)
     org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
    org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
    org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
    org.eclipse.core.databinding.observable.Realm.runWithDefault(Rea
    lm.java:332)
     org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workben
    ch.java:668)
     org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java
    :149)
     com.ibm.mdt.app.Application.start(Application.java:85)
    org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseApp
    Handle.java:196)
     org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.ru
    nApplication(EclipseAppLauncher.java:110)
     org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.st
    art(EclipseAppLauncher.java:79)
     org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStar
    ter.java:353)
     org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStar
    ter.java:180)
     sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessor
    Impl.java:88)
     sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMetho
    dAccessorImpl.java:55)
     java.lang.reflect.Method.invoke(Method.java:618)
    org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
     org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
    org.eclipse.equinox.launcher.Main.run(Main.java:1438)
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * All Users                                                    *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * See error description.                                       *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Upgrade to TM1 10.2 RP2 FP2                                  *
    ****************************************************************
    

Problem conclusion

  • Code Fix
    

Temporary fix

Comments

APAR Information

  • APAR number

    PI19295

  • Reported component name

    TM1 PERFORM MOD

  • Reported component ID

    5724W49PF

  • Reported release

    A20

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2014-06-04

  • Closed date

    2014-12-19

  • Last modified date

    2014-12-19

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    TM1 PERFORM MOD

  • Fixed component ID

    5724W49PF

Applicable component levels

  • RA22 PSN

       UP



Document information

More support for: Cognos TM1
TM1 Performance Modeler

Software version: 10.2

Reference #: PI19295

Modified date: 19 December 2014