IBM Support

PH21213: Unable to update WebSphere Application Server Liberty V8.5 version 19.0.0.12 to 20.0.0.1 using IBM Installation Manager.

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

APAR status

  • Closed as program error.

Error description

  • When customers update WebSphere Application Server Liberty
    V8.5 from fixpack version 19.0.0.12, 19.0.0.11, or 19.0.0.10
    to fixpack version 20.0.0.1 using IBM Installation Manager,
    IBM Installation Manager will issue an error and terminate
    the fixpack update operation with the following message.
    
    ERROR: Cannot roll back to package
    com.ibm.websphere.liberty.ND.v85 version
    8.5.20001.20200108_0300 because it is not installed.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  All users of IBM WebSphere Application      *
    *                  Server Liberty V8.5 who are using IBM       *
    *                  Installation Manager                        *
    ****************************************************************
    * PROBLEM DESCRIPTION: Unable to update WebSphere Application  *
    *                      Server Liberty V8.5 version 19.0.0.12   *
    *                      to 20.0.0.1 using IBM Installation      *
    *                      Manager.                                *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    Customers cannot update their existing installation of WebSphere
    Application Server Liberty V8.5 from version 19.0.0.12,
    19.0.0.11, or 19.0.0.10 to fixpack version 20.0.0.1 using IBM
    Installation Manager.
    
    In IBM Installation Manager silent mode, users will get an error
    message similar to the one below when they are trying to update
    their existing installation to fixpack version 20.0.0.1.
    
    ERROR: Cannot roll back to package
    com.ibm.websphere.liberty.ND.v85 version
    8.5.20001.20200108_0300 because it is not installed.
    
    In IBM Installation Manager GUI mode, users will not be able to
    select the fixpack of WebSphere Application Server Liberty V8.5
    version 20.0.0.1 from the GUI panels during fixpack update
    operation even when the correct repository is specified.
    

Problem conclusion

  • After the problem is fixed, customers will be able to update
    their existing installation of WebSphere Application Server
    Liberty V8.5 from version 19.0.0.12, 19.0.0.11, or 19.0.0.10 to
    fixpack version 20.0.0.2 using IBM Installation Manager.
    
    The fix for this APAR is currently targeted for inclusion in fix
    pack 20.0.0.2.  Please refer to the Recommended Updates page for
    delivery information:
    http://www.ibm.com/support/docview.wss?rs=180&uid=swg27004980
    

Temporary fix

  • When customers upgrade their WebSphere Application Server
    Liberty V8.5 version 19.0.0.10, 19.0.0.11, or 19.0.0.12
    installation to fixpack version 20.0.0.1, customers can install
    WebSphere Application Server Liberty V8.5 fixpack version
    20.0.0.1 to a new installation location and reference the shared
    resources and server definitions from their previous WebSphere
    Application Server Liberty V8.5 version 19.0.0.10, 19.0.0.11, or
    19.0.0.12 installation location using the environment variable
    WLP_USER_DIR.  Customers can refer to the following document for
    more details.
    
    https://www.ibm.com/support/knowledgecenter/SSEQTP_liberty/com.i
    bm.websphere.wlp.doc/ae/twlp_admin_customvars.html
    

Comments

APAR Information

  • APAR number

    PH21213

  • Reported component name

    LIBERTY PROFILE

  • Reported component ID

    5724J0814

  • Reported release

    855

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2020-01-20

  • Closed date

    2020-01-22

  • Last modified date

    2020-01-22

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    LIBERTY PROFILE

  • Fixed component ID

    5724J0814

Applicable component levels



Document information

More support for: WebSphere Application Server

Software version: 855

Reference #: PH21213

Modified date: 22 January 2020