IBM Support

PH18236: INCORRECT JAVA 7 EOS WARNING MESSAGE ON WAS 8.5.5.13 (JAVA 6)

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

APAR status

  • Closed as program error.

Error description

  • When updating Java 7/7.1 to latest fixpack 8.5.5.16 on
    WebSphere Application Server 8.5.5.13 (with default Java 6
    installed), Installation Manager show Java 7 EOS warning
    message:
    
    By July 2022, switch to the default Java SE 8 SDK provided by
    the WebSphere Application Server traditional package in the
    same package group. With the Java SE 8 SDK, you continue to
    receive support, including security updates and fixes.
    
    This is not correct because the default Java is Java SE 6 SDK.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  All users of IBM WebSphere Application      *
    *                  Server                                      *
    ****************************************************************
    * PROBLEM DESCRIPTION: Message shows switching to default      *
    *                      Java 8 when updating Java 7/7.1 on      *
    *                      WebSphere Application Server 8.5.5.13   *
    *                      (default Java 6)                        *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    Current message is for WebSphere Application Server 8.5.5.14
    and up or WebSphere Application Server 8.5.5.13 or lower with
    default Java 8 installed.
    

Problem conclusion

  • The fix is to add a new message to handle WebSphere
    Application Server 8.5.5.13 or lower with default Java 6
    installed. The message asks updating WebSphere Application
    Server 8.5.5.13 or lower to 8.5.5.14 or up.
    
    The fix for this APAR is currently targeted for inclusion in
    fix pack 8.5.5.17.  Please refer to the Recommended Updates
    page for delivery information:
    http://www.ibm.com/support/docview.wss?rs=180&uid=swg27004980
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH18236

  • Reported component name

    WEBS APP SERV N

  • Reported component ID

    5724H8800

  • Reported release

    850

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2019-10-18

  • Closed date

    2020-01-13

  • Last modified date

    2020-01-13

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WEBS APP SERV N

  • Fixed component ID

    5724H8800

Applicable component levels



Document information

More support for: WebSphere Application Server
General

Software version: 850

Reference #: PH18236

Modified date: 13 January 2020