IBM Support

PH17654: WSVR0661W STARTS TO HAPPEN AFTER THE APPLICATION OF 8.5.5.16

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

APAR status

  • Closed as program error.

Error description

  • WSVR0661W was introduced by PH05460, but we always see it if we
    install additional language option.
    For example, in the output
    of versionInfo command, we see the following output in the env
    where the language option is installed.
    ----
    Optional Languages
    Japanese
    ----
    
    In the osgi console, we will see the following
    bundle state is "INSTALLED" and this results in
    WSVR0661W.
    ---
    osgi> ss
    148 INSTALLED
    com.ibm.ws.security.crypto.nls.ja_7.0.0
    ---
    
    The jar file surely
    exists.
    # ls -l
    /opt/IBM/WebSphere/AppServer85ND/plugins/nls/eclipse/plugins/ |
    grep security
    -rw-r--r--. 1 root root 635 Jul 18 13:19
    com.ibm.ws.security.crypto.nls.ja.jar
    
    Since WSVR0661W starts to
    happen just after the application of FP16 in every environment
    where the language option is installed, it should be suppressed
    if it's harmless.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  All users of IBM WebSphere Application      *
    *                  Server who installed language options in    *
    *                  addition to English                         *
    ****************************************************************
    * PROBLEM DESCRIPTION: WSVR0661W is printed at server          *
    *                      startup about                           *
    *                      com.ibm.ws.security.crypto.nls jar      *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    com.ibm.ws.security.crypto.nls.xxx.jars do not have language
    related functions.  They can be safely removed.  This APAR
    removes the jars so that unnecessary warnings are not
    printed in the log.
    

Problem conclusion

Temporary fix

  • There is no functional issue. The warning can be ignored.
    

Comments

APAR Information

  • APAR number

    PH17654

  • Reported component name

    WEBS APP SERV N

  • Reported component ID

    5724H8800

  • Reported release

    900

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2019-10-02

  • Closed date

    2019-11-12

  • Last modified date

    2019-11-12

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WEBS APP SERV N

  • Fixed component ID

    5724H8800

Applicable component levels



Document information

More support for: WebSphere Application Server
General

Software version: 900

Reference #: PH17654

Modified date: 12 November 2019