IBM Support

PH08482: MAKE CLIENTAPPLCOMPAT OPTIONAL FOR DB2 CONNECT 11.1 FIXPACK 1 OR HIGHER

A fix is available

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as new function.

Error description

  • DB2DDF DB2DRDA E92110 S92260
    Make clientApplCompat optional for Db2 Connect 11.1 Fixpack 1
    or higher.
    ***************************************************************
    Additional Symptoms and Keywords:
     SQLCODE -30025 SQLCODE30025 SQL30025N SRN30025
     DSNL076I MSGDSNL076I
     clientApplCompat
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * All Distributed Data Facility (DDF) users.                   *
    * Db2 12 for z/OS users only.                                  *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * Allow clientApplCompat property to                           *
    * be optional for Db2 Connect V11.1                            *
    * Fixpack 1 or higher client                                   *
    * environments.                                                *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Apply corrective PTF when available                          *
    ****************************************************************
    Db2 12 for z/OS requires that Data Server Driver client
    environments specify a clientApplCompat connection/global
    property value when executing Db2 12 packages bound with an
    APPLCOMPAT value of V12R1M501 or higher.  Part of the reason
    for requiring clientApplCompat to be specified was to ensure
    that the client environment has been upgraded to a driver
    level, V11.1 Fixpack 1 (or higher), that has been validated
    to support Db2 APPLCOMPAT V12R1M501 or higher packages (since
    only an upgraded driver would support the clientApplCompat
    specification).  Failure to specify the clientApplCompat
    property, relative to APPLCOMPAT V12R1M501 or higher Db2
    packages, will cause Db2 to reject the client connection with
    SQLCODE -30025.  A companion DSNL076I message may also be
    issued.
    The specification of the clientApplCompat property is too
    difficult for users to manage.  Db2 administrators are finding
    it difficult to coordinate with all their client application
    teams on when and how to set the clientApplCompat property.
    Also, Db2 Connect gateway environments do not support the
    clientApplCompat property so gateway users are forced into an
    unplannned migration off their gateway environment.
    The impact of requiring the clientApplCompat property to be
    specified, even when the client driver environments have been
    upgraded (to V11.1 Fixpack 1 or higher), is preventing users
    from binding their packages to APPLCOMPAT V12R1M501 or higher
    function.
    

Problem conclusion

  • Db2 is changed to allow the clientApplCompat connection/global
    property specification to be optional.
    However, there is still value in requiring that client driver
    environments be upgraded to V11.1 Fixpack 1 (or higher) when
    executing packages that are bound to support (APPLCOMPAT)
    V12R1M501 or higher function.  Db2 will therefore continue to
    reject client connections if the client Driver environment, or
    Db2 Connect Gateway, is down level with respect to the Db2
    package APPLCOMPAT value.
    
    Associated Db2 documentation changes are necessary.
    
    SQLCODE -30025
    The Database administrator response (the description of the
    "product-identifier:*:package-applcompat-value" condition) is
    changed as follows:
    ---------------------------------------------------------------
    Database administrator response
    
    If reason-code is 0600, use clientapplcompat-value and
    package-applcompat-value to determine the cause of the error
    and fix the problem:
    * If identifier is in the format
      product-identifier:clientapplcompat-value:
      package-applcompat-value, ...
    
    * If identifier is in the format
      product-identifier:*:package-applcompat-value, a client
      application compatibility value was not set for the
      application, but package-applcompat-value is greater than
      V12R1M500 and the client environment is back level with
      respect to package-applcompat-value.
      The client or driver is not at a level that supports the
      package APPLCOMPAT level package-applcompat-value. Take one
      of the following actions:
      o If possible, upgrade the client or driver.
          Refer to https://www.ibm.com/support/knowledgecenter/en/
        SSEPEK_12.0.0/apsg/src/tpc/db2z_applcompatclients.html for
        information regarding required client driver levels.
        Once upgraded, it is also recommended, but not required,
        that the client application compatibility value for the
        application be set to the package-applcompat-value or less.
    
      o If it is not yet possible to upgrade the client or driver,
        bind or rebind the driver packages with APPLCOMPAT set to
        V12R1M500 or less.
    
      For drivers only, you can use the DSNTIJLC job to bind copies
      of the driver packages, or the DSNTIJLR job to rebind the
      driver packages, at the correct application compatibility
      level.
    
      If you bind copies of the driver packages, you need to modify
      the configuration keyword or bind option that controls the
      current package set so that applications use the correct set
      of driver packages.
    ---------------------------------------------------------------
    
    Message DSNL076I.
    The Database administrator response (the description of the
    "If clientapplcompat reflects a value of * (asterisk)"
    condition) is changed as follows:
    ---------------------------------------------------------------
    Database administrator response
    
    You can assist the client application user in resolving their
    problem. Action depends on the clientapplcompat-value value.
    
    If clientapplcompat-value reflects a value of * (asterisk), a
    client application compatibility value was not set for the
    client application, but package-applcompat-value is greater
    than V12R1M500 and the client environment is back level with
    respect to package-applcompat-value.
    The client or driver is not at a level that supports the
    package APPLCOMPAT level package-applcompat-value. Take one of
    the following actions:
    o If possible, upgrade the client or driver.
       Refer to https://www.ibm.com/support/knowledgecenter/en/
       SSEPEK_12.0.0/apsg/src/tpc/db2z_applcompatclients.html for
       information regarding required client driver levels.
       Once upgraded, it is also recommended, but not required,
       that the client application compatibility value for the
       application be set to the package-applcompat-value or less.
    
    o If it is not yet possible to upgrade the client or driver,
      bind or rebind the driver packages with APPLCOMPAT set to
      V12R1M500 or less.
    
    You can use the DSNTIJLC job to bind copies of the driver
    packages, or the DSNTIJLR job to rebind the driver packages, at
    the correct application compatibility level.
    
    If you bind copies of the driver packages, you need to modify
    the configuration keyword or bind option that controls the
    current package set so that applications use the correct set of
    driver packages.
    
    If clientapplcompat reflects a value other than *
    (asterisk), ...
    ---------------------------------------------------------------
    
    IBM Knowledge Center is updated for this change:
    http://www.ibm.com/support/knowledgecenter/SSEPEK
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH08482

  • Reported component name

    DB2 OS/390 & Z/

  • Reported component ID

    5740XYR00

  • Reported release

    C10

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2019-02-12

  • Closed date

    2019-04-08

  • Last modified date

    2019-05-02

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

    UI62393

Modules/Macros

  • DSNLXRSS
    

Fix information

  • Fixed component name

    DB2 OS/390 & Z/

  • Fixed component ID

    5740XYR00

Applicable component levels

  • RC10 PSY UI62393

       UP19/04/19 P F904

Fix is available

  • Select the PTF appropriate for your component level. You will be required to sign in. Distribution on physical media is not available in all countries.



Document information

More support for: DB2 for z/OS

Software version: 12.0

Reference #: PH08482

Modified date: 02 May 2019