IBM Support

IT16279: GATEWAYSCRIPT VULNERABILITY IN THE V8 COMPONENT OF IBM DATAPOWER GATEWAYS (CVE-2016-1669)

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • V8 may improperly expand memory allocations.  This could
    potentially be used to cause a Denial of Service through buffer
    overflow.
    

Local fix

Problem summary

  • Affected is the use of GatewayScript.
    
    GatewayScript is based on V8 engine, which may improperly expand
    memory allocations. This could potentially be used to cause a
    Denial of Service through buffer overflow.
    

Problem conclusion

Temporary fix

Comments

APAR Information

  • APAR number

    IT16279

  • Reported component name

    DATAPOWER

  • Reported component ID

    DP1234567

  • Reported release

    700

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2016-07-25

  • Closed date

    2016-09-13

  • Last modified date

    2016-09-15

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    DATAPOWER

  • Fixed component ID

    DP1234567

Applicable component levels

  • R700 PSY

       UP

  • R710 PSY

       UP

  • R720 PSY

       UP

  • R750 PSY

       UP

  • R751 PSY

       UP

  • R752 PSY

       UP



Document information

More support for: IBM DataPower Gateways
General

Software version: 7.0.0

Reference #: IT16279

Modified date: 15 September 2016