IBM Support

IJ17392: GETTING /NULL ERROR WHEN OPENING ATTACHMENTS USING IE11.

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

APAR status

  • Closed as program error.

Error description

  • PROBLEM:
    
    Users can not open attachments in Maximo 7.6.1 using Internet
    Explorer 11.
    They can open attachments using Edge, Chrome and Firefox.
    The issue is intermittent, sometimes the attachment link will
    open the document and other times the document will not open.
    
    When opening the attachment with IE 11, a second browser tab
    opens as expected but we see this:
    http://maximo/maximo/webclient/skins/skins-20190523-1640/iot18/i
    mages/null
    
    Error in log:
    [5/30/19 17:09:41:186 CDT] 00000164 filter E
    com.ibm.ws.webcontainer.filter.FilterInstanceWrapper doFilter
    SRVE8109W: Uncaught exception thrown by filter
    HttpMaxAgeFilter: java.io.FileNotFoundException: SRVE0190E:
    File not found:
    /webclient/skins/skins-20190523-1640/iot18/images/null
    
    PERFORMANCE ISSUE: No.
    
    STEPS TO REPRODUCE:
    Try to open an attachment using IE11.
    
    CURRENT ERRONEOUS RESULT:
    When opening the attachment with IE 11, a second browser tab
    opens as expected but we see this:
    http://maximo/maximo/webclient/skins/skins-20190523-1640/iot18/i
    mages/null
    
    EXPECTED RESULT:
    When opening the attachment with IE 11 the file should be
    opened successfully.
    
    ENVIRONMENT (SYSTEM INFO)
    Tivoli's process automation engine 7.6.1.0
    

Local fix

  • N/A
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * IE11 users                                                   *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * GETTING /NULL ERROR WHEN OPENING ATTACHMENTS USING IE11      *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    

Problem conclusion

  • Fixed in library.js
    

Temporary fix

Comments

APAR Information

  • APAR number

    IJ17392

  • Reported component name

    SYSTEM CONFIG

  • Reported component ID

    5724R46S1

  • Reported release

    761

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2019-07-03

  • Closed date

    2019-07-15

  • Last modified date

    2019-07-15

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    SYSTEM CONFIG

  • Fixed component ID

    5724R46S1

Applicable component levels



Document information

More support for: Maximo Asset Management

Software version: 761

Reference #: IJ17392

Modified date: 15 July 2019