IBM Support

IJ08593: METER READINGS HAVE THE WRONG TIME SPECIFIED

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

APAR status

  • Closed as program error.

Error description

  • Problem:
    Meter readings do not have the correct time specified. Compare
    the attachments between meter readings and asset downtime, they
    both have different times. The meter reading is using my
    browser and the downtime is using the user setting.
    
    Setup:
    1. On Maximo Classic, open Assets application and create an
    asset
    2. Associate a CONTINUOUS meter to the asset
    3. Open Work Order Tracking application
    4. Create a work order associated to the asset above
    5. Add the Work Execution work center user as owner of the work
    order
    6. Approve the work order
    
    Steps:
    1. Log into Work Execution work center
    2. Open the work order created
    3. In details page, click on Up toggle option inside asset tile
    4. Verify date when the card flips
    
    Actual Result: The downtime is using the user settings to
    display the date.
    
    5. On Asset meter reading panel, click on plus icon
    6. Verify date when the card flips
    
    Actual Result: The meter reading is using my browser's settings
    to display the date.
    
    Expected Result: Both dates should use browser's settings to
    display the date.
    
    Problem: As stated above.
    Root Cause: Not checking the client specific date format
    properly after flips the asset or location related tiles.
    Remedy: Added the code related to checking the client specific
    date format after flips the asset and location related tiles.
    

Local fix

  • n/a
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * MAXIMO                                                       *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * Not checking the client specific date format properly after  *
    * flips the asset or location related tiles.                   *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    

Problem conclusion

  • Added the code related to checking the client specific date
    format after flips the asset and location related tiles. Tested
    the QA team and working fine.
    

Temporary fix

Comments

APAR Information

  • APAR number

    IJ08593

  • Reported component name

    SYSTEM CONFIG

  • Reported component ID

    5724R46S1

  • Reported release

    761

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2018-08-17

  • Closed date

    2019-01-16

  • Last modified date

    2019-01-16

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    SYSTEM CONFIG

  • Fixed component ID

    5724R46S1

Applicable component levels

  • R761 PSY

       UP



Document information

More support for: Maximo Asset Management

Software version: 761

Reference #: IJ08593

Modified date: 16 January 2019