IBM Support

IC99197: DBYPASS_TSM_REQ_CHECKS=TRUE OPTION FOR V7.1 DOESN'T ALLOW INSTALL TO COMPLETE IF A PREREQUISITE IS NOT MET

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as documentation error.

Error description

  • The V7.1 Installation Guide states for the installation of a
    server or a storage agent says;
    
    "On test servers only: Use the following command to bypass
    prerequisite checks such as the operating system and the
    required memory. Do not issue this command on a production
    server.
    
    ./install.sh -g -vmargs "-DBYPASS_TSM_REQ_CHECKS=true"
    or
     install.bat -g -vmargs "-DBYPASS_TSM_REQ_CHECKS=true"   "
    
    But install still fails if a prerequisite is not met.
    For example on a test Unix host with less than 12GB of memory;
    
    ./install.sh -vmargs "-DBYPASS_TSM_REQ_CHECKS=true"
    
    opens Installation Manager GUI
    Error: 'The system does not meet the minimum memory requirement
    of 12 GB'.
    Next and Install buttons are greyed out, unable to proceed.
    
    ./install.sh -c -vmargs "-DBYPASS_TSM_REQ_CHECKS=true"
    
    opens Installation Manager CLI
    * [ERROR] IBM Tivoli Storage Manager server 7.1.0.20131126_1825
    contains
    validation errors.
         1. ERROR: The system does not meet the minimum memory
    requirement of 12 GB.
    No option to continue.
    
    
    Tivoli Storage Manager Versions Affected:
    Tivoli Storage Manager Server 7.1.x on all platforms
    
    
    
    
    Initial Impact: Low
    
    Additional Keywords:
    zz71 install bypass prereq DBYPASS_TSM_REQ_CHECKS vmargs
    

Local fix

  • Invoke Installation Manager directly with the command line flag.
    (example below is for Unix)
    For the GUI version:
    
    /opt/IBM/InstallationManager/eclipse/IBMIM -vmargs
    "-DBYPASS_TSM_REQ_CHECKS=true"
    
    For the CLI version:
    
    /opt/IBM/InstallationManager/eclipse/tools/imcl -c -vmargs
    "-DBYPASS_TSM_REQ_CHECKS=true"
    
    Both of these have the same effect, downgrading the prereq
    failure from
    Error to Warning, thereby allowing the Tivoli Storage Manager
    server installation to continue.
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED: All Tivoli Storage Manager server users.     *
    ****************************************************************
    * PROBLEM DESCRIPTION: See error description.                  *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    *
    

Problem conclusion

  • Information about bypassing the prerequisite checks is
    available in Technote 1664640 at:
    http://www.ibm.com/support/docview.wss?uid=swg21664640
    
    The same information will be added to the Tivoli Storage
    Manager Installation Guide and Storage Agent User's Guide, in
    the "Using the installation wizard", "Using the console
    installation wizard", and "Using silent mode" topics.
    
    Affected platforms: AIX, HP-UX, Solaris, Linux, and Windows.
    

Temporary fix

Comments

APAR Information

  • APAR number

    IC99197

  • Reported component name

    TSM SERVER

  • Reported component ID

    5698ISMSV

  • Reported release

    71L

  • Status

    CLOSED DOC

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2014-02-06

  • Closed date

    2014-02-21

  • Last modified date

    2014-02-21

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

Applicable component levels



Document information

More support for: Tivoli Storage Manager

Software version: 71L

Reference #: IC99197

Modified date: 21 February 2014