IBM Support

R710 IBM i Access for Windows install results in InstallShield error 1158.

Technote (troubleshooting)


Problem(Abstract)

Customer applied PTF SI57907 on IBM i server. Copied i Access > Windows directory via QIBM NetServer share. Attempt to install R710 IBM i Access for Windows with this merged image results in InstallShield error 1158.

Symptom

R710 IBM i Access for Windows install fails.


Cause

In this specific case, the message is received because there is something wrong with the install image.

Environment

R710 i5/OS with PTF SI57907 Permanently Applied for Licensed Program 5770XE1. Windows Server 2012 R2 Standard 64bit with R610 IBM i Access for Windows and Service Pack SI42423. There are no security suite installed

Diagnosing the problem

The following message is received when IBM i Access for Windows install is attempted:

TITLE: InstallShield.
MESSAGE: 1158: Error populating strings. Verify that all strings in Setup.ini are valid.


There is little information available on the InstallShield site, here is what InstallShield's "setup.exe Error Codes" listed:

Error: 1158
Description: Error populating strings
Troubleshooting Tips: Verify that all strings in Setup.ini and any language-specific INI files in the Disk1 folder (such as 0x0409.ini) are valid.

Resolving the problem

In this case we copied the install image to the PC from another (working) IBM i server that has good copy, with the current PTF level for 5770XE1 Licensed Program applied. The install completed successfully.


Other recovery methods:

Method 1:
    If you do have IBM i Access for Windows to another IBM i server, with 5770XE1 installed and has the current PTF applied, then you can fix the image on the problematic system by following these steps (IPL is not required):
    1. On the working system:
      • CRTSAVF FILE(QGPL/LPP5770XE1) TEXT('Good copy 5770XE1 LPP.')
      • SAVLICPGM LICPGM(5770XE1) DEV(*SAVF) SAVF(QGPL/LPP5770XE1)
      • FTP the QGPL/LPP5770XE1 save file to the failing system.
    2. On the failing system:
      • DLTLICPGM LICPGM(5770XE1)
      • RSTLICPGM LICPGM(5770XE1) DEV(*SAVF) SAVF(QGPL/LPP5770XE1)
      • Apply (immediate) current 5770XE1 PTF.
      • Copy the image to the PC for installation.
Method 2:
    If you do not have IBM i Access for Windows to another IBM i server, then you can fix the image on the IFS by following these steps (IPL is not required):
    • DLTLICPGM LICPGM(5770XE1)
    • RSTLICPGM LICPGM(5770XE1)
    • Apply (immediate) current 5770XE1 PTF.
    • Copy the image to the PC for installation.
Method 3:
    Create a merged image on the PC using base image from the Install IBM i Access for Windows DVD (PC-side) media, or good copy of base image from IBM i server:
    • Create a new folder on your PC, call it "IBM i Access Merged Image 7.1".
    • Copy all the contents of the base image from the DVD, or the IBM i server, to this folder.
    • Download the current IBM i Access for Windows Service Packs (32bit and 64bit) from the IBM i Access Windows website and save them into the same folder.
    • Follow steps outlined in Downloads.txt file, section "3.1 Update Installation Image" to create the merged image.
    • Copy the merged image to the PC for installation.


Cross reference information
Segment Product Component Platform Version Edition
Operating System IBM i 7.2
Operating System IBM i 7.1
Operating System IBM i 6.1

Document information

More support for: IBM i
Access for Windows

Software version: 5.4.0, 5.4.5, 6.1, 6.1.0, 6.1.1, 7.1, 7.1.0, 7.2, 7.2.0

Operating system(s): Windows

Reference #: N1021144

Modified date: 11 June 2018