IBM Support

IBM: z/VSE - Service and support - Introduction


IBM: z/VSE - Service and support - Introduction

Introduction

You are encouraged to keep your z/VSE system on a healthy service level. In order to do that it is recommended to update you z/VSE system to stay on a supported release and service level.

z/VSE Service pyramid

To order preventive service like PSP buckets or RSLs, please navigate to the preventive service page.

 

For information on how to order and apply PTFs please refer to the How to order page.

Back to top

Hot service news

Date Description
August 22, 2018 z/VSE 6.2.0, 6.1.0, & 5.2.0 RSL have been updated to the June 30, 2018 level.
May 25, 2018 Upload of customer data requires IBM Id
Starting May 25th, upload of customer material for problem determination changes. Before upload of material, all customers must identify with their IBM Id. Furthermore plain FTP server for manual data upload will be discontinued. Instead FTPS (FTP over TLS) encryption will be enforced to meet legal requirements. For more details see the Enhanced Customer Data Repository (ECuRep) web page.
May 8, 2018 Tape delivery in Shopz will be discontinued
As stated in the IBM Software Announcement 218-118 dated March 6, 2018, on July 1, 2018, delivery of PTFs for z/OS, z/VM, and z/VSE on tape is planned to be discontinued with an effective date of July 16, 2018. IBM plans to support Internet and DVD delivery options for product and PTF delivery in Shopz. For further details see Washington Systems Center Flash 10889
Feb 23, 2018 z/VM 6.4 APAR to fix a problem when the z/VSE VTOC is located at the end of the volume
APAR VM66104 / PTF UM35279
Feb 19, 2018 IBM ShopZ may return PTFs for End-of-Service release VSE/ESA 1.1.0 if the order was based on a report generated by the z/VSE Installed Software Report Tool and IPv6/VSE was listed in z/VSE 6.2 history file. The superfluous PTFs will be sorted out by MSHP when installing the PTFs. Clients with no license for IPv6/VSE should run job DELIPV6 from ICCF library 59 to remove product from the library and from the system history file.
Jan 15, 2018 z/VSE 6.1.0 & 5.2.0 RSL have been updated to the Dec 30, 2017 level.
December 11, 2017 After z/VSE 6.2 installation the the LIBDEF procedure needs to be updated:
Both products, TCP/IP and IPv6/VSE, are pre-installed on your z/VSE system.
  • TCP/IP is installed in sublibrary PRD2.TCPIPC
  • IPv6/VSE is installed in sublibrary PRD2.TCPIPB
Depending on which product you selected to use, the sublibrary PRD2.TCPIPC or PRD2.TCPIPB must be added to the LIBDEF Procedures. Use skeleton SKLIBCHN in ICCF library 59 to maintain your LIBDEF procedure.
December 1, 2017 IBM z/VSE V6.2 is available
Aug 1, 2017 z/VSE 6.1.0 & 5.2.0 RSL have been updated to the Jun 30, 2017 level.
July 17, 2017 Running z/VSE V5.2 on a IBM z14:
For the AR REIPL command the PTF for APAR DY47722 is required. For automatic installation of z/VSE 5.2 in a z14 LPAR and ECKD disks: After restore of IJSYSR1 is complete (message on console), system enters hardwait FFD (because REIPL fails). Circumvention: After restore of IJSYSR1, when system entered hardwait, IPL DOSRES device manually. Then automatic installation then continues normally.
Feb 1, 2017 z/VSE 6.1.0 & 5.2.0 RSL have been updated to the Dec 31, 2016 level.
July 19, 2016 The GPS Feature of IBM TCP/IP for z/VSE V2.1 is available for z/VSE V6 customers.
  • Customers using the GPS Feature of IBM TCP/IP for z/VSE on z/VSE V6.1, require a new license for the new version of the feature when ordering z/VSE V6.1.
  • As of July 22, only V2.1 of the GPS Feature is available for ordering with z/VSE V6.1.
  • IBM TCP/IP for z/VSE - GPS V2.1 is eligible for Migration Pricing Option (MPO).
In order to ensure licensing for IBM TCP/IP for z/VSE - GPS V2.1, you need to select the product when ordering z/VSE V6.1 in Shopz, or by placing an additional order if you have ordered z/VSE V6.1 already. For more information please see the Announcement letter
July 11, 2016 z/VSE 6.1.0, 5.2.0 & 5.1.2 RSL have been updated to the June 30, 2016 level.
June 30, 2016 z/VSE V5.1 end of service
April 25, 2016 z/VSE 6.1.0 PSP Bucket Shopz orders
At the moment (as of April 25, 2016) there is no HIPER flagged service available for z/VSE 6.1.0. This means there is no need to place a PSP bucket order on Shopz when you have just installed the new z/VSE 6.1.0 release.
If you have already placed such a PSP Bucket order for z/VSE 6.1.0, then you will receive PTF's for a back level release of EREP (5656-260-01-D10) which can be ignored. If you try to install them, you will receive message: 'Product 260D10 is not installed on your system'. This can then be ignored.
April 4, 2016 A new license is required for the new versions of IBM TCP/IP for z/VSE V2.1 and CICS TS for z/VSE V2.1 on z/VSE V6.1
  • Customers using IBM TCP/IP for VSE/ESA V1.5 on z/VSE V5, require a new license for the new version of IBM TCP/IP for z/VSE V2.1 when ordering z/VSE V6.1.
  • Customers using CICS TS for VSE/ESA V1.1.1, require a new license for the new version of CICS TS for z/VSE V2.1 when ordering z/VSE V6.1.

In order to ensure licensing for the new TCPIP and CICS TS product versions, you need to select the product(s) applicable when ordering z/VSE V6.1 in Shopz, or by placing an additional order for either of the products, if you have ordered z/VSE V6.1 already.

z/VSE V6.1 only supports CICS TS for z/VSE V2.1 and IBM TCP/IP for z/VSE V2.1. Older versions of these two products are not supported with z/VSE V6.1.
Feb 10, 2016 z/VSE 6.1.0 RSL has been created at the Jan 15, 2016 level and z/VSE 5.2.0 & 5.1.2 RSL have been updated to the Jan 15, 2016 level.
November 27, 2015 IBM z/VSE V6.1 is now available
Oct 1, 2015 z/VSE 5.2.0 & 5.1.2 RSL updated to the Aug 31, 2015 level.
May 1, 2015 z/VSE 5.2.0 & 5.1.2 RSL updated to the Apr 30, 2015 level.
March 23, 2015 HIPER APAR PI35643/PI35642 DATA SEQUENCE ERROR WHEN USING Z/VSE FAST PATH TO LINUX ON SYSTEM Z:
In case you are using the z/VSE Fast Path to Linux on System z (LFP) ensure that PTF UI25399/UI25398 for APAR PI35643/PI35642 is installed. This PTF updates the Linux Fast Path daemon (LFPD). Make sure that you download the WBOOK IJBLFPLX.W and update the LFPD on Linux (using rpm -u). You can also download the latest LFPD code here.
Dec 31, 2014 z/VSE 5.2.0, 5.1.2 & 4.3.1 RSL updated to the Dec 31, 2014 level.
Dec 18, 2014 Impact of POODLE (CVE-2014-3566) on z/VSE (PDF, 105KB)
October 31, 2014 z/VSE V4.3 end of service
Jul 1, 2014 z/VSE 5.2.0, 5.1.2 & 4.3.1 RSL updated to the Jun 30, 2014 level.
May 30, 2014 z/VSE 5.2.0 RSL has been added at the May 23, 2014 level. z/VSE 5.1.2 RSL & z/VSE 4.3.1 RSL updated to the May 16, 2014 level.
May 23, 2014 The IJSYSPF file (used to apply service from disk) was delivered with an incorrect definition on z/VSE 5.2. In order to apply service from disk it is necessary to redefine this file prior to service application. This can be done by changing and then submitting skeleton SKPTFILE in library 59 from:
RECORDSIZE (80,10320)       -
RECORDFORMAT(FIXBLK(10320)) -
to
RECORDSIZE (80,10320)       -
RECORDFORMAT(FIXBLK(80))    -
This skeleton is corrected in PTF UI17100. Once the IJSYSPF file has been redefined, if a PTF is to be transferred using TCP/IP the file must be transferred as follows:
ftp> binar 
200 Command okay.
ftp> quote site recfm fb
200 Command okay.
ftp> quote site lrecl 80
200 Command okay.
ftp> quote site blksize 10320
200 Command okay.
ftp> put ptffile.bin PTF.FILE
Note: If you used FSU to upgrade to z/VSE 5.2, then this skeleton SKPTFILE may not be available in your  library 59. You can then use this job to restore it from the z/VSE 5.2 base tape. After you have restored it, you need to change it as described above and then submit it to redefine IJSYSPF.
May 9, 2014 APAR DY47526 is available for z/VSE 5.1. It solves a problem created by a fix in error for DY47507, which results in error message MSG4228I RC X'22' VOLSER IN DLBL NOT MATCH CATALOG DEFINITION. This code is in the base of z/VSE 5.2 and the APAR DY47537 is available for z/VSE 5.2.
April 25, 2014 IBM z/VSE V5.2 is now available
Feb 15, 2014 z/VSE 5.1.2 RSL & z/VSE 4.3.1 RSL updated to the Jan 31, 2014 level.
Dec 1, 2013 z/VSE 5.1.2 RSL & z/VSE 4.3.1 RSL updated to the Oct 31, 2013 level.
Nov 13, 2013 Important info on APAR PM80542/UK91650
With APAR PM80542/UK91650, which was included in z/VSE 5.1.2 Upgrade, the transaction security phase DTSECTXN was delivered by error. This phase will get active in the system replacing transaction security settings for IBM provided transactions in case the new security concept based on BSTCNTL definition is used. If not yet migrated to the new concept it will even replace all customer defined transaction security settings.

In case the new concept is used (you can find out using IUI dialog 285, you will not get migration offered) delete DTSECTXN.PHASE from IJSYSRS.SYSLIB.

If the old concept is used, there should be the original phase stored in PRD2.SAVE, the new (IBM transactions only) phase in IJSYSRS.SYSLIB. It is recommended to merge the new IBM definition into existing setup as follows:
  1. Run the following REXX procedure
    // EXEC REXX=IPFTABLE,     * 
    PARM='IJSYSRS.SYSLIB.DTSECTXS.A 
            IJSYSRS.SYSLIB.DTRISEC.U'
    |
    +--- 2nd line starts at column 16
    
  2. In dialog 285 specify do not migrate, use PF5 merge key and process key after verifying your transactions are included. This will replace the wrongly delivered DTSECTXN phase.

Error symptoms:
  1. If on new concept, IBM provided transactions will run with default authorization, that means if for example CEMT transaction was moved out of GROUP01, after above PTF CEMT is authorized for GROUP01 again.
  2. If on old concept, IBM provided transactions will be authorized for standard setup, but transactions for user applications are not authorized anymore.
Sep 30, 2013 PM75512: RPG II users should apply PTF UK83060 when migrating to z/VSE V5.1. Batch RPG II applications that use the SETLL operation may abend or have unpredictable results when accessing VSAM control blocks in 31 bit storage.
Oct 31, 2012 z/VSE V4.2 end of service
Jul 26, 2012 PM67737: Customers who have developed, maintained or rebuilt COBOL/VSE applications on z/VSE 5.1 prior to installing UK80309 should apply this APARs PTF and then re-link all z/VSE 5.1 updated COBOL/VSE applications. COBOL/VSE applications that have not been linkedited on z/VSE 5.1 are not affected and do not require any action. APAR PM69182 is available for z/VSE 4.3 COBOL/VSE users as a preventative solution.
Jun 21, 2012 FSU from 5.1.0 to 5.1.1.
  1. Before running any FSU step, please install following patch (on 5.1.0):
    // JOB CORRECT
    *  MSHP PERSONALIZE FUNCTION 
    *  TO KEEP OLD DATE
    // EXEC MSHP
    CORRECT 5686-CF-907-51C : DY99955
    AFFECTS PHASES=MSHPCOMM
    ALTER 2EE8C 47E0C2B6:47F0C2B6
    RESOLVES 'NEW DATE WITH PERSONALIZE'
    /*
    /&
    
  2. Use dialog 'Defragment History File' fastpath 147
  3. now continue with FSU - Downlevel Check, Preparation and Installation.
If this information was missed and the message M063I is issued, the related job will fail and job DTRFSUAB will get active (Stage 2, not with the Downlevel Check). Customer may try following (does not work for sure in all cases):
enter
0 exit
r rdr,pausefsu
0 ALLOC BG=16M
0 SIZE BG=1280K
0
r rdr,dtrfsuab
...
0 resume
If this does not work and M063 is still issued, enter
l rdr,dtr*
and reipl from DOSRES and coontinue with step 1 above. The whole FSU needs to be rerun in this case.
Jun 15, 2012 z/VSE V5.1.1 is now available
Sep 27, 2011 Important z/VSE V4.3 migration considerations regarding recoverable VSAM catalogs
Aug 12, 2011 z/VSE V4.3.1 is now available
Aug 2, 2011 Effective October 31, 2012, z/VSE V4.2, CICS/VSE V2.3, DL/I V1.10 and DL/I V1.11 will be withdrawn from service
Nov 26, 2010 z/VSE V4.3 is now available
Oct 14, 2010 New z/VSE Problem Determination Guide is available
Jul 15, 2009 Updated list of PTFs for ACF/VTAM V4.2 31-bit I/O Buffer support
In 2006 IBM introduced the ACF/VTAM V4.2 31-bit I/O Buffer support. This support needs additional PTFs for its full functionality. For a complete list of PTFs for z/VSE 3.1 or z/VSE 4.1 or z/VSE 4.2 see here.
 

Document information

More support for: z/VSE family

Software version: 6.2

Operating system(s): z/VSE

Reference #: T1027442

Modified date: 22 August 2018


Translate this page: