Troubleshooting
Problem
Warehouse Proxy Agent configured to connect to an MS-SQL Database fails with the error “JVMCFRE003 bad major version”
Symptom
During the configuration of the Warehouse Proxy Agent using the GUI the following error is display when attempting to test the connection to the data warehouse.
Cause
The error indicates the JDBC driver does not include expected SQLServerDriver.class.
Diagnosing The Problem
This issue can be encountered if the Warehouse Proxy Agent (WPA) is loading an unexpected *jdbc.jar file.
Using the Operating System command 'lsof' confirm the JDBC files being loaded by the ITM 6 Agent.
- Use the cinfo command to confirm the PID for the WPA. example: $CANDLEHOME/bin/cinfo -r | grep hd
- Using the PID associated with the WPA confirm the *jdbc.file being loaded by the WPA: <br>lsof -p <PID> | grep jdbc
An example showing the WPA loading multiple SQL jdbc files:
khdxprtj 11650 root 52r REG 253,0 1163656 603983883 /opt/IBM/ITM/JRE/lx8266/lib/ext/mssql-jdbc-7.2.2.jre8.jar
khdxprtj 11650 root 53r REG 253,0 900895 536933140 /opt/IBM/ITM/database_drivers/sqljdbc41.jar
The valid SQL Server JDBC when connecting to a MS-SQL database is sqljdbc41.jar.
Resolving The Problem
1) Stop the WPA
2) Move the invalid SQL jdbc file from the $CANDLEHOME/JRE/lx8266/lib/ext to a different location. In the example above the invalid SQL jdbc file is "/opt/IBM/ITM/JRE/lx8266/lib/ext/mssql-jdbc-7.2.2.jre8.jar".
3) Start the WPA
4) Using the lsof command confirm the only jdbc file being loaded by the WPA is the sqljdbc41.jar
- lsof -p <pid> | grep jdbc
Document Location
Worldwide
[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSTFXA","label":"Tivoli Monitoring"},"Component":"Warehouse Proxy Agent;Summarization and Pruning Agent","Platform":[{"code":"PF016","label":"Linux"}],"Version":"6.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
Was this topic helpful?
Document Information
Modified date:
26 July 2019
UID
ibm10960900