Question & Answer
Question
Within WebGUI 8.1 the datasource page opens as a blank page.
Cause
Within WebGUI logs the following error message can be seen at around the time when the datasource page is being opened:
Caused by: com.ibm.isc.datastore.Datastor eException: page does not exists, page cannot be served: compName=com.ibm.tivoli.em.isc module, navName=item.admin.navigationE lement.DataSourceEditor
Caused by: org.eclipse.emf.ecore.xmi.Unre
Answer
If this error is seen in the logs and there are several corrupted xml files under the following directory:
/opt/IBM/JazzSM/profile/confi g/cells/JazzSMNode01Cell/appli cations/isc.ear/deployments/is c/OMNIbusWebGUI.war/WEB-INF/
the FixConfiguration tool might be try in order to see if it can fix those xml file as documented within the following technical note:
https://www-01.ibm.com/support/docview.wss?uid=swg21698398
but if this won't help then restore the xml files from a backup taken at a moment when everything worked fine by replacing the current ones and restart WebGUI afterwards.
They can also be copied from a server with the same WebGUI version as an alternative.
If there are no backup taken or similar server, then raise a case with IBM and upload the content of the mentioned directory so that the files to be fixed.
[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSSHTQ","label":"Tivoli Netcool\/OMNIbus"},"Component":"WebGUI","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
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Document Information
Modified date:
12 July 2019
UID
ibm10959121