Troubleshooting
Problem
Attempting to run the command /opt/IBM/ITM/lx8266/iw/scripts/updateTEPSEPass.sh results in the error
WASX7023E: Error creating "SOAP" connection to host "localhost"; exception information: com.ibm.websphere.management.exception.ConnectorNotAvailableException: [SOAPException: faultCode=SOAP-ENV:Client; msg=Unable to find a valid IP for host localhost]
Full details of the error can be located in the file /opt/IBM/ITM/<arch-type>/iw/profiles/ITMProfile/logs/wsadmin.traceout
Cause
This error is encountered when the TEPS process is either not running or the TEPS has not fully initialized.
Diagnosing The Problem
Confirm the TEPS process is running using the command 'cinfo -r'
If the TEPS process is running the cinfo output returns these lines to the terminal:
Host Prod PID Owner Start ID ..Status
cyclops63 kf 10446 root 08:46 None ...running
cyclops63 cq 10541 root 08:46 None ...running
cyclops63 kf 10446 root 08:46 None ...running
cyclops63 cq 10541 root 08:46 None ...running
If the TEPS process shows running confirm the TEPS process is fully initialized by reviewing the $CANDLEHOME/logs/kfwservices.msg.
A TEPS process is fully initialized and available to accept request only after the text "Waiting for requests. Startup complete" appears in the kfwservices.msg file.
Resolving The Problem
Start the TEPS using the command 'itmcmd agent start cq'
Document Location
Worldwide
[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSTFXA","label":"Tivoli Monitoring"},"Component":"TEPS","Platform":[{"code":"PF016","label":"Linux"}],"Version":"6.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
Was this topic helpful?
Document Information
Modified date:
28 June 2019
UID
ibm10957775