IBM Support

One user gets "Standard Error 5 ... The ConnectionString property has not been initialized" error, triggered by resuming an old (disconnected) Excel session, which has timed out

Troubleshooting


Problem

User launches 'main' Controller client. User clicks on some functionality (for example 'Reports - Run' or clicks on 'Controller link' X icon) which triggers Excel to launch.
An error message appears (in Excel).

Symptom

The exact error may vary (depending on the function being triggered) but the error will look similar to this:
image-20190412121301-1
Standard Error
Error Details:
Number 5
Source: ControllerProxyClient
Description: System.Web.Services.Protocols.SoapException: Server was unable to process request .---> System.Exception: The ConnectionString property has not been initialized. at Cognos.Controller.Proxy.ControlleReportNetService.RepNet.GetUserInfo (String sGuid, String sUser, String passportId)
at Cognos.Controller.Proxy.CCRWS.GetUserInfo(String sGuid, String sUser, String passportID) -- End of...
<...>
Cognos.Controller.Forms.Common.fFrmFrangoFunc.InitExcelLink
<....>
Cognos.Controller.Forms.Formfrm.ReportRun.RunReport...
<....>

Cause

There are many possible causes for "The ConnectionString property has not been initialized" errors
  • See separate IBM Technote #1963432 for more scenarios.
This Technote specifically relates to the scenario where the cause is that the end user has re-connected to an old 'disconnected' session (which was still running on the Citrix server), that has timed out of its authentication.
More Information:
In order to achieve other requirements (for example security) some environments (such as Controller on Cloud) will have timeouts associated with them, for example (Controller on Cloud 10.3.1):
  • Citrix idle timeout of 30 minutes
  • Cognos Analytics / IIS application pool timeouts (for example 10 hours).
If a user exits their Cloud Excel session 'cleanly' (by closing Microsoft Excel in the expected way) then this session gracefully ends, and the problem does not occur.
If a user does not exit their Cloud Excel session cleanly (for example they leave their laptop running unattended for over 30 minutes, thereby causing the idle timeout to eject their connection) then the Excel session will run 'in the background' (on the Citrix server, but invisible to the end user). This is known as a 'disconnected' session.
  • The disconnected session can last for many days (it will not get killed unless there is a maintenance window where the Citrix server gets rebooted).
Example:
In one real-life customer example:
  • UserA used Controller/Excel. Afterwards, the Citrix session became 'disconnected' (with Excel still running)
  • One month later, UserA re-launched Controller. When clicking "Reports - Run" it caused the old session of Excel to be reactivated (on the Citrix server). The error appeared because (many days ago) the CA/IIS timeouts had been exceeded.

Environment

This problem could (potentially) affect any customer using Citrix (or Terminal Services) to deploy Controller.
  • However, it has been seen with Controller-on-Cloud 10.3.1.

Resolving The Problem

Fix:
Make sure that you logoff from Controller/Excel cleanly, when you have finished using the software (for example at the end of the working day).
  • In other words, do not simply leave the cloud Excel session 'disconnected' (running in Cloud but not visible on the end user's PC).
Steps to logoff from Controller/Excel cleanly:
See separate IBM Technote #1978164.
Workaround:
When the error occurs, simply:
  • Close Excel and Controller
  • Re-launch Controller (from the Citrix icon)
  • Re-try.

Document Location

Worldwide

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Document Information

Modified date:
12 October 2021

UID

ibm10880855