Troubleshooting
Problem
User launches Controller client. An error appears.
Problem only affects one user. All other users can successfully logon OK.
Symptom
An error occurred while trying to access the server
Details:
System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.IndexOutOfRangeException: Index was outside the bounds of the array. at
Cognos.Controller.Proxy.ControllerReportNetService.RepNet.GetUserInfo (String sGuid, String sUser, String passportId) at
Cognos.Controller.Proxy.CCRWS.GetUserInfo(....
<...
at CCR.AppContext.DoLogin()
at CCR.AppContext.Login()
Cognos.Controller.Proxy.ControllerReportNetService.RepNet.GetUserInfo (String sGuid, String sUser, String passportId) at
Cognos.Controller.Proxy.CCRWS.GetUserInfo(....
<...
at CCR.AppContext.DoLogin()
at CCR.AppContext.Login()
Cause
Limitation of Controller in some environments.
Environment
The problem has been seen (rarely) in some Controller on Cloud environments.
Resolving The Problem
The affected ('bad') user should logoff their Windows session (running on the relevant Citrix server).
- NOTE: This does not mean that the user should logoff from the Citrix website (for example Citrix Netscaler website). Instead, the user must perform the steps (below) which logs their Windows session off (from the Citrix server).
Afterwards, re-launch the Controller client.
Steps:
There are other methods of achieving a logoff from Citrix (see separate IBM Technote #1978164 for more examples).
- Below is the simplest method for most circumstances:
1. IMPORTANT: Make sure that the Controller application (with the error message described above) is:
(a) visibly running on your screen
(b) and highlighted/selected/in-focus.
2. On your keyboard, tap the following keys simultaneously: CTRL F1
- The following screen should appear:
3. Click 'Sign Out'
4. Inside the Citrix website, launch the Controller icon. This time it will work OK (no error).
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMRTZ","label":"IBM Cognos Controller on Cloud"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
12 October 2021
UID
ibm10876974