IBM Support

Delete Person process fails on Delete Person in Domino Directory request

Troubleshooting


Problem

When using the Admin client to delete a user, the Delete Person in Domino Directory request fails and the process does not continue.  The user has been deleted from the Directory but they remain in groups and their mail file is still present.  The response document reports the error that the "File does not exist" and lists admin4.nsf.  This issue is captured in SPR RJTOB9ANCA.


Cause

This occurs in Domino 10.0 and 10.01 when the option "Delete the mail database on the user's home server" is selected and the option "Delete mail replicas on all others server" is checked.  Also, the server has to not be in a cluster.  The actual file that does not exist is cldbdir.nsf.  If the server is in a cluster and the database repair option is enabled the issue will not occur.

Resolving The Problem

There are 3 Options to workaround the issue:

1) Install 10.0.1 FP1 when available
2) Restore the person document from backup and re-delete them without checking the "other replicas" option 
3) Use the "Add Person" form action to add a 'stub' person (i.e. do not register the user).  
Putting in the user name and mail file info (Domain, mail server, mail file) and then re-deleting them without checking the "other replicas" option.  Both options require that any other replicas of the mail file have to be deleted manually.

Document information

More support for: IBM Domino

Component: Administration Process

Software version: 10.0, 10.0.1

Operating system(s): AIX, Linux, Windows

Reference #: 0872404

Modified date: 05 March 2019