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OutOfMemoryException errors and performance degradation caused by the CleanUpUnusedReferences task for DOORS Next Generation

Troubleshooting


Problem

Attempts to run CleanUpUnusedReferences task for IBM DOORS Next Generation (DNG) fails with OutOfMemoryException errors or causes performance degradation.

Symptom

  • The typical symptom of a performance issue related to this task running is within the Active Services page in rm/admin.
  • A Java OutOfMemoryException error can occur when resources are exhausted.

Cause

The cleanupUnreferencedVersions task removes unused versions from the Jena index and is scheduled to run periodically. When there are a lot of unreferenced versions, this task can cause performance issues due to the transaction size set in the Advanced Properties of the DNG application being too large for some system's sizing.

Use Cases where this has been observed:

1. When this task is set to run during production hours, somewhere in the world, then the performance issues have an increased chance of occurring.

2. Where significantly large data changes have occurred (deletion of projects, or significant updates via CSV bulk update/ReqIF)


Diagnosing The Problem

If there is an Out Of Memory exception, then this will be evident in the /java directory there will be a javacore file.

1TISIGINFO    Dump Event "systhrow" (00040000) Detail "java/lang/OutOfMemoryError" "Java-Heap Space" received

 This is also evident in the application log, for example rm.log:

2019-01-01 08:30:49,434 [rm.jfs.indexer.triple.live ] [ INFO] com.ibm.team.jfs - Unused indexes cleanup task, GraphNames deleted so far: 751234
2019-01-01 08:44:59,461 [rm.jfs.indexer.triple.live ] [ERROR] com.ibm.team.jfs - CRJZS5856E An unexpected error occurred during a write trans

java.lang.OutOfMemoryError: Java-Heap Space
    at java.nio.HeapByteBuffer.<init>(HeapByteBuffer.java:57)

If you are experiencing poor performance then the simplest way to confirm this is within the Active Services page of the DNG Admin window. You will see the task explicitly mentioned and it will persist for some time, consuming resources.


Resolving The Problem

If you have experienced any performance issues or Out of Memory Exception errors, then you will need to reduce the transaction size to a level more manageable by the system.

Command line instructions:

  1. Stop the DOORS Next Generation web server
     
  2. Edit <JazzInstallationFolder>/server/conf/rm/teamserver.properties ) and add the line:
    com.ibm.team.jfs.jena.tdb.transaction.size.cleanup.task=1000
     
  3. Restart the DOORS Next Generation web server for this change to take effect.

GUI instructions:

  1. Open rm/admin > Advanced Properties
     
  2. Search for the Advanced Property "Indexes cleanup transaction size"
     
  3. Change the value from 20000 to 1000
     
  4. Restart the DOORS Next Generation web server for this change to take effect.

Document information

More support for: Rational DOORS Next Generation

Software version: 6.0.6

Operating system(s): Platform Independent

Reference #: 0796082

Modified date: 08 April 2019