IBM Support

Can't drill-through on PDF report

Troubleshooting


Problem

This document addresses the issue where drill-through links do not work in a PDF report.

Symptom

When exporting report to PDF with drill-through, the child links do not work and the user is unable to drill through from the parent report.
  1. Drill-through works in other report formats but not with PDF.
  2. Issue occurs through the dispatcher as well as the gateway.
  3. Issue occurs in all browsers.

Cause

Drill-through reporting when exporting as a PDF is only supported in IE with the Adobe plug-in installed. Using any other browser, or exporting to PDF in IE without the plug-in will result in a regular PDF file being generated, with no drill-through links.

Resolving The Problem

  • Add the Adobe PDF Plug-in to your Internet Explorer browser:
    1. Open Internet Explorer, and choose Tools > Manage Add-ons.

    2. Under Add-on Types, select Toolbars And Extensions.

    3. In the Show menu, select All Add-ons. Select All Add-ons from the Show menu in the Manage Add-ons dialog box.

    4. In the list of add-ons, select Adobe PDF Reader.

    5. Click the Enable or Disable button (it toggles depending on the status of the selected add-on):

      • Enable sets the Adobe PDF Reader add-on to open PDFs in the browser. Disable turns off the add-on so it does not open PDFs in the browser.

    6. Select Adobe PDF Reader, and click the Enable/Disable button.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0.x","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
22 January 2019

UID

ibm10787497