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Considerations when migrating to z/OS 2.3 with the Transparent Cloud Tiering (TCT) maintenance installed or when installing the Transparent Cloud Tiering maintenance to lower level systems

Troubleshooting


Problem

There are several components involved with the new function TCT. They are HSM, SMS, and ISMF and all the involved maintenance needs to be installed to avoid errors.

Users Affected

Any users migrating to z/OS 2.1, z/OS 2.2, or z/OS 2.3 where the ServerPac order includes TCT maintenance and have an SMSplex with lower-level systems where TCT maintenance is not applied. Or any users applying TCT maintenance to their current system(s) within an SMSplex. These APARs include OA52901, OA52913, and OA52914 and all COREQs/PREREQs associated.

Overview of Maintenance

Before any TCT maintenance is applied to any systems, you must ensure the HSM conditioning PTF for OA54677 is applied to every system that shares the SMS CDS. An IPL is not required to apply the conditioning PTF.

Be sure to take a backup of the current SCDS and ACDS before installing OA52901/OA52913/OA52914 maintenance.

Once the conditioning PTF for HSM is installed to all systems in the SMSplex, you can proceed with installing OA52901/OA52913/OA52914.  These PTFs can be applied with a rolling IPL one system at a time. 
NOTE: Until the maintenance is applied to all systems, any ISMF work and SMS activations must be performed on the systems where OA52913/OA52914 are applied.

 
            

Be aware that the new TCT maintenance increases the size of the SMS SCDS/ACDS. Activating a configuration can result in messages IGD058I and IGD040D RETURN CODE(0008) REASON(6068). Increasing the CDS size resolves this error.


 

Symptom

Here are some known problems encountered when all of this maintenance is not applied at the same time. These issues are encountered in ISMF and NaviQuest when accessing management classes for alter or display.

1.  ISMF Internal Error and Message DGTUV035 RETURN CODE(0012); REASON(0611) and REASON(3218) when listing all management classes (by using *) or listing management classes using a generic i.e. TEST*.  Listing a single specific management class works.

2.  ISMF Internal Error and Message DGTUV024 RETURN CODE(0008); REASON (0642), (3366), (3308) and (3309) when altering a management class in ISMF.

3. For HSM errors with Recall, Migrate, Expire by and DCOLLECT functions after OA52913 is applied to a system in the plex.

4. ISMF Internal Error and Message DGTUV024 RETURN CODE(0008) REASON (3306) when attempting to display management classes by using generic '*' on a system without the TCT maintenance.  The display shows one management class then fails.  Displaying a specific management class works.

5. "UPLEVEL CDS WARNING" is issued when attempting to update the SCDS or activate the SMS configuration from a system without the TCT maintenance where another system within the SMSplex with the TCT maintenance has updated the SCDS.

6. ISMF Internal error and DGTUV024 RETURN CODE(0008) REASON(0635) and REASON(0349) which listing all management classes.  See II04577 for an explanation of this specific error: http://www-01.ibm.com/support/docview.wss?uid=isg1II04577
 

 

Cause

Some causes of these symptoms are:

a. APAR OA52913 (and PE APAR OA55733) along with OA52914 are applied on a system and SMS configuration activity (especially mgmt class display, alter, delete, or add) is performed in ISMF or NaviQuest on a separate system in the SMSplex that does NOT have the PTFs applied.      

                                                                                                                  *OR*                                                                                                                                           
b. APARs OA52913 (and PE APAR OA55733) and OA52914 have not ALL been applied on the LPARs where mgmt class activity is being performed in ISMF or NaviQuest.                                                       

*OR*                                                                                                                                   

c. All PTFs are installed but the ISMF concatenation points to an older set of ISMF libraries (review II04577 to ensure ISMF concatenation is correct).

*OR*

d. IPL'ing a system with the TCT maintenance installed where the SCDS was updated and some or all of the other systems in the SMSplex do not have the TCT maintenance applied

Resolving The Problem

 Ensure all of the TCT maintenance is applied on the LPAR where the SMS changes are being performed.

If the issue is that the ISMF concatenation points to an older set of ISMF libraries, follow the instructions in II04577 for details on how to properly set up the ISMF libraries.
 
http://www-01.ibm.com/support/docview.wss?uid=isg1II04577

For details specific to DFSMShsm please refer to the following link:

https://www.ibm.com/support/pages/hsm-fails-recall-migrate-expirebv-and-dcollect-functions-after-oa52913-applied-system-plex

                   

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Document Information

Modified date:
03 September 2021

UID

ibm10738095