Troubleshooting
Problem
User launches the 'main' Controller client. User clicks the 'X' button (labelled 'Controller Link'). An error appears.
Problem only affects one user.
Symptom
Example (Controller 10.3.1):
Error Launching menu item "Controller Link"
Details:
Cannot run the macro 'cc.CompareDb'. The macro may not be available in this workbook or all macros may be disabled.
Cause
There are many different scenarios for similar "Cannot run the macro 'cc.CompareDb'. The macro may not..." errors.
- TIP: For more examples, see separate IBM Technote #1971878.
This Technote specifically relates to the scenario where the cause is that there is a 'stuck' (hung / crashed) session of Excel (running on the client device) which needs to be closed down.
Example:
In one real-life customer example, there were two 'stuck' sessions of Excel (visible - running on the task bar and also clickable on).
Resolving The Problem
Fix:
Close the 'stuck' Excel sessions (running in the background) and re-try.
Example:
In one real-life customer example, it was not possible to click on the 'X' button (in the top-right corner of Excel) to close those Excel sessions down. If the user did that, then nothing seemed to happen.
- Instead, the user had to click "File - Close" (inside Excel) to close those 'stuck' Excel sessions.
Workaround:
Logoff from Windows. Then re-logon to Windows (to get a brand-new/fresh session).
- TIP: If using Citrix, then the steps to logoff from Citrix are described inside separate IBM Technote #1978164.
Related Information
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Document Information
Modified date:
16 October 2018
UID
ibm10735329