IBM Support

The ASoC IDE plugin for both Eclipse and Microsoft Visual Studio fail to log in or fail to connect to the ASoC Service.

Troubleshooting


Problem

The tool exhibit one or more of the following symptoms:

  • IDE plugin hangs indefinitely at "Checking application association..."
  • Repeatedly ask for Key ID and Key Secret when attempting to run Static Analysis
  • Returns an error similar to "A connection to the Static Analyzer scan manager service could not be established"
  • Returns an error similar to "Unable to Authenticate with the service"

Cause

The plugin uses a small application server to communicate with ASoC.

This application server is failing to start because it is picking up an unsupported version of Java.

This can include older versions of Java but it can also be caused by the Oracle's Java 10 or later.

Diagnosing The Problem

Verify the version of Java

Check the JAVA_HOME variable.

set JAVA_HOME

If it returns "Environment variable JAVA_HOME not defined"  we may be using the version of Java from the PATH variable.

Run the following on Windows to verify

>where java

This will list all java executables on the path. The first one is the one that will be picked up by the plugin.

Get the version of java

<path from above commands>\java -version

Only version's 8 and 9 are currently supported.

Test the  key \secret with the following command.

cd to the bin directory of an existing SAClient and run the following command.

appscan api_login -u key_id -P key_secret

There may already be an SAClient installed into the user's home directory.

C:\Users\<username>\.appscan\SAClient<version>

If there is not one there it can be downloaded.  See the links at the bottom of this document.


Resolving The Problem

Set JAVA_HOME  to point to a a supported version of Java as a System variable on Windows.

Restart the IDE

Note when this problem occurs the process causing the problem may not stop when the IDE is restarted.

The host can be rebooted to avoid this problem.

If the server cannot be rebooted find and kill the javaw.exe process with "\wlp\bin\tools\ws-javaagent.jar" in the "Command Line" column of Windows Task Manger.

Note the command line column is not visible by default.  See your OS documentation for information on how to add it.

Following are shortened examples of the command line with the information required to verify that it is the correct process.

Visual Studio:

"-javaagent:C:\Users\<user>\AppData\Local\Microsoft\VisualStudio\14.0\Extensions\mqlwro2f.xjg\wlp\bin\tools\ws-javaagent.jar"

Eclipse:
"-javaagent:C:\eclipse\plugins\com.ibm.appscan.eclipse.plugin_1.0.0.201806280232\lib\wlp\bin\tools\ws-javaagent.jar"

 

The SAClient will contain a supported versions of Java and can be downloaded from the following locations

Example JAVA_HOME

JAVA_HOME=C:\SAClientUtil.6.0.1256\jre

If further assistance is required from support please send in the output of the following commands.

Windows

wmic /OUTPUT:"C:\users\<your username>\processlist.txt" process get description,executablepath,commandline

Linux\MacOS

ps -ef |grep -i eclipse >processlist.txt

Send in processlist.txt


Document information

More support for: IBM Application Security on Cloud

Software version: All Versions

Operating system(s): Windows

Reference #: 0732025

Modified date: 26 March 2019