IBM Support

"The ConnectionString property has not been initialized" when opening Data Entry form, caused by AppSense

Troubleshooting


Problem

User launches the 'main' Controller client. User clicks 'Company - Data Entry - Reported Values'. Excel launches. An error appears in Excel.

The problem occurs all the time (it is not intermittent).

Symptom

image-20180911132914-1

Standard Error

image-20180911132953-2

Details:

The ConnectionString property has not been initialized

Cause

There are many different possible causes for the error 'The ConnectionString property has not been initialized'.

  • TIP: For more examples, see separate IBM Technote #1963432.

 

This Technote specifically relates to the scenario where the cause is that the client device (typically the Citrix server) has AppSense installed/configured, which is forcing the Excel link to use the 'wrong' ccr.config file.

 

More Information

For the avoidance of doubt, IBM does not support the use of AppSense with Cognos Controller.

  • If a customer chooses to use AppSense, then they do so at their own risk
  • IBM reserves the risk to ask customers to reproduce any problem outside of the AppSense environment (in other words, without using AppSense). If the problem cannot be triggered when AppSense is removed, then IBM reserve the right to stop giving support for the issue.

Environment

Client device has AppSense (Ivanti) installed/configured.

  • Typically this means a Citrix server.

Diagnosing The Problem

Launch the 'main' Controller client. Click on the green 'X' button (to launch 'Controller Link'). Excel loads.

Afterwards, click on the 'Controller' Excel add-in. Notice how the user is not logged on yet ('Log off' is greyed out):

image-20180911140225-1

Resolving The Problem

For the avoidance of doubt, IBM officially does not support the use of AppSense with Cognos Controller.

  • The guidance below is purely given as a courtesy, on a (best endeavour) 'as is' basis.
  • Customers follow this advice at their own risk.

 

Fix:

Reconfigure AppSense to exclude the file 'ccr.config' (located inside "%APPDATA%\Cognos\ccr").

 

Steps:

Inside the relevant AppSense tool, right-click on the 'ccr.config' file and choose 'Exclude':

image-20180911133652-1

 

Workaround:

Disable AppSense.

 

Steps:

On the Citrix server, stop (and disable) the Windows service 'AppSense User Virtualization Manager':

image-20180911135957-2

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
11 September 2018

UID

ibm10731143