Question & Answer
Question
How can you remove a nonstandard offline managed system? The naming convention of the managed system is not following the standard naming convention.
Cause
The offline managed system that follows standard naming conventions can be removed with the "tacmd cleanms" command. If the managed systems are created with nonstandard characters, the agent cannot be so easily deleted.
https://www.ibm.com/support/knowledgecenter/SSTFXA_6.2.3/com.ibm.itm.doc_6.2.3/linuxos623_user11.htm#wq18
Answer
To remove the nonstandard managed systems, you could use one of the following options. In this technote, the nonstandard char is blank but this technote is applicable to any nonstandard chars
Option 1 : A blank char is not allowed in the managed system name. To remove the managed system with the blank char, use following procedure to clear the offline systems
Make a copy of the following file. Then, edit the following xml file.
Windows: $candlehome\BIN\\ml\kuicleanmsVld.xml
Linux/UNIX : $candlehome/$arch/ue/xml/kuicleanmsVld.xml
Replace this part of the xml file ValidationRegExp="[-A-Za-z0-9_:.#\$]" with ValidationRegExp="[-A-Za-z0-9 _:.#\$]"
Note: There is a blank added after 0-9 in the previous line. In this way, the blank character is legal in the agent name.
Then, execute the tacmd cleanms with double quotation marks around the managed system to remove the offline managed system
ex : tacmd cleanms -m "nc 136237:LZ"
Option 2 : You can use the kdstsns tool and the following SQL to remove the offline managed system from the Tivoli Enterprise Monitoring Server database. The scope of the tool is not addressed in this technote.
More detail about the KDSTSNS was documented in an earlier troubleshooting manual. For reference here is the text:
KDSTSNS enables you to access the Tivoli Enterprise Monitoring Server internal
tables and to manually retrieve data which is not usually available through the
Tivoli Enterprise Portal. To use this tool, complete the following steps:
1. Create an .sql file containing the definition of your SQL query and place the file
in the SQLLIB directory of your installation (for example, nodelist.sql).
2. From the ITM-Install-Dir\CMS directory, run kdstsns.
3. When the utility starts, you can interact with it (for example, see the sample
lines):
a. Enter NCS Address Family :ip.pipe
b. Enter NCS Host Name (default: #198.210.62.101 ):lab232155
c. Enter NCS Server Port Number (eg. 1024, ....):1918
d. Enter SQL member name (or “end” to quit) ...nodelist.sql
At this point, the query in the .sql file has been executed and the results can be
analyzed. The short form of the command to send output into a file is as follows:
C:\IBM\ITM\cms>kdstsns nodelist.sql *HUB > mynodelist.txt
DELETE FROM O4SRV.TNODELST
WHERE NODE LIKE "manage system name*";
DELETE FROM O4SRV.TNODESAV
WHERE NODE LIKE "manage system name*";
DELETE FROM O4SRV.TOBJACCL
WHERE NODEL LIKE "manage system name*";
To verify the removal, you can use this SQL
SELECT NODE, NODELIST, NODETYPE, LSTDATE, LSTUSRPRF
FROM O4SRV.TNODELST
WHERE NODE LIKE "manage system name*";
SELECT NODE,NODETYPE,ORIGINNODE,PRODUCT,THRUNODE
FROM O4SRV.TNODESAV
WHERE NODE LIKE "manage system name*";
SELECT NODEL, OBJNAME
FROM O4SRV.TOBJACCL
WHERE NODEL LIKE "manage system name*";
Refer to this document link for naming convention for standard managed system (instance)
https://www.ibm.com/support/knowledgecenter/SSTFXA_6.2.3/com.ibm.itm.doc_6.2.3/linuxos623_user11.htm#wq18
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Document Information
Modified date:
26 October 2021
UID
ibm10718279