IBM Support

WebSphere Application Server Detailed System Requirements

Product Documentation


Abstract

The list below identifies the supported releases of IBM® WebSphere® Application Server from which you can select specific detailed system requirements.

Content

 



These pages describe the minimum product levels you should have installed before opening a problem report with the WebSphere Application Server support team. Because other products frequently ship fixes, updates, and new releases, we cannot test every possible configuration. In general, you can install and run with updates to supported products if those updates are forward-compatible. For additional information on available support for configurations that are not included in the following list, refer to support article WebSphere Application Server has grown and so have your requirements.

For additional information on support provided for WebSphere Application Server when used with OSS Frameworks, refer to support article WebSphere Application Server OSS Framework Support Statement.

For information specific to IBM HTTP Server standalone, please refer to this report.

For information specific to WebSphere Liberty, please refer to the 8.5.5 or 9.0 report.

Required levels of WebSphere Application Server to support hourly metering:

  • WebSphere Liberty 18.0.0.3 or higher
  • WebSphere Application Sever V9.0.0.9 or higher
  • WebSphere Application Server V8.5.5.13 or 14 along with APAR PH01810


Note that your entitlement to support, if any, is dependent upon your license and/or maintenance agreements for WebSphere Application Server and is limited to your use of the relevant prerequisite with a supported WebSphere Application Server product.
 


 


 

 

 

 


 


Version 9.0 WebSphere Application Server:

WebSphere Application Server (all editions)
WebSphere Liberty
Edge Components
Hypervisor

 


Version 8.5.5 WebSphere Application Server:

WebSphere Application Server (all editions)

WebSphere Liberty
Application Client for WebSphere Application Server
Hypervisor

Notice: Java SE 6 is being removed from service. Java SE 8 is the recommended Java SDK because it provides the latest features and security updates. You can continue to use Java SE 6, but no service can be provided after the end of the support date, which might expose your environment to security risks.
See
Knowledge Center for more details.
For Edge components, see
technote.

Back to top


 

Version 8.5 WebSphere Application Server:

Base

Network Deployment and Edge Components
Developers
Express
z/OS
Application Client for WebSphere Application Server
Hypervisor

Back to top

 


Version 8.0 WebSphere Application Server:

Base

Network Deployment and Edge Components
Developers
Express
z/OS
Application Client for WebSphere Application Server
Hypervisor

 

 


Version 7.0 WebSphere Application Server:

WebSphere Application Server (all editions)

Hypervisor Edition
Unsupported configurations

 

 

Cross reference information
Product Component Platform Version Edition
WebSphere Application Server - Express General AIX, HP-UX, Linux, Solaris, Windows 7.0, 6.1, 6.0.2, 6.0.1, 6.0
Runtimes for Java Technology Java SDK
WebSphere Application Server Hypervisor Edition General Linux 7.0, 6.1
WebSphere Application Server for z/OS z/OS 7.0, 6.1, 6.0

Document information

More support for: WebSphere Application Server

Component: General, Java SDK

Software version: 6.0, 6.0.1, 6.0.2, 6.1, 7.0, 8.0, 8.5, 8.5.5, 9.0.0.0

Operating system(s): AIX, HP-UX, IBM i, Linux, Solaris, Windows, z/OS

Software edition: Advanced, Base, Enterprise, Express, Network Deployment, Single Server

Reference #: 7006921

Modified date: 27 September 2018


Translate this page: